Landscape problems

Has anyone found a fix for this yet? or an answer to why this is still happening. https://www…com/watch?v=1JZTbZT8ffk&

I have had this happen since day one and we are now on 4.1 and I am still having this problem. This is not my video but it shows my problem exactly. I have fully given up on the landscape feature and have had to use mesh planes or sculpting a mesh in other applications to have a ground to walk on. This is very irritating, I don’t mind using mesh but I loved using the landscape feature to prototype with and figure out my level.

Any answer or response that may enlighten me on what is going on or if this will ever be fixed would be great. Thanks!

Hi ,

How many textures are you using on one landscape segment? In the video it looks like he has reached the maximum number of textures (13) allowed on any given segment of landscape. This is an issue we are currently assessing but if a user has more than that on one segment of landscape it will default to the gray texture until materials are removed.

I managed to set it up with the weightblend instead of the Heightblend and it works fine for me this way. For some reason using heightblend with up to 3 different textures will cause the problem shown above. Using the weightblend I have 6 different textures and it works fine.

with the heightblend, are you using multiple normals as well as textures?

Hi ,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please post with the requested information. Thank you!

I would like to see this issue reopened because I’m having the same problem. Here’s my landscape material. It has 4 materials but I can only connect normals, albedo and 3/4 of the roughness maps. Right now I just have the last RMA packed map unplugged and I have a constant in it’s place. As soon as I plug in that last roughness map I get the same result as the posted video, tiles painted with the 4th mat change to the world grid mat and never update. I’ve tried switching between height and weight blending but that didn’t help either.

Hey D3F3N357R40R,

Take a look at this post where I answered a similar question. You are basically hitting the texture sample limit for landscapes, and need to use the ‘Shared:Wrap’ feature to exceed this limitation set by the Shader Model you are using.

Let me know if you have additional questions.


I am still having this problem in 4.25, not even just with texture painting but with flat out just importing textures as masks during the “import tiled landscape” dialogue box in world composition.

Setting the texture sampler to “Shared Wrap” fixes it… In a single test file that i have since backed up and have not been able to reproduce, because if i even modify the master material the slightest bit, it breaks again permanently.

“Shared Wrap” is not the issue here… In fact, the only difference i can tell between the single test project that actually worked (of 20) and the actual current project i’ve been trying to import a tiled landscape to is that on the test project, one of the normal maps somehow has the sampling mode set to color instead of normal and if i try to fix this, it breaks everything. I’ve tried everything, even deleting my DerivedDataCache, nothing works. It is unacceptable to me that this is even a bug, i don’t know how anyone has ever actually made a functioning game with this engine because i have literally been at this for weeks and i can’t seem to figure out what is causing this.