Download

Landscape painting problem

Hi
Ive been painting my first landscape and have run into a problem. A few segments are acting strange, They turned black with the exeption of some squares that had texture in them. I repainted them but they are behaving weirdly as they are gettin painted with the wrong texture, for example the bottom layer, the rock works fine. The second dirt layers dosent work on these squares. But when i paint with grass it paints with another layer. Anyone know how i could fix this? The problem started (i think) when i changed the texture size in landscape coords for 2 textures.

try using ‘LP weight blends’ at .5x.5x.5… i think i tried this (alpha) a long time ago and i had to erase all the alpha weights one at a time to go down… but it did seem that last time i worked on a landscape i had a similar problem having to erase my way down… umm, i think a black square means you have too many paints on one square (4 i think), but don’t quote me on that (smile)…

Hi, thank you for the reply, changing to LP Blend Weights made the painting error behave differently but its still there. How did you erase the layers? Is it possible to do it only on the buggy terrain squares or do i have to erase and paint the whole landscape again?

you use “shift” when you paint to erase… just whatever layer you see, select it then ‘shift’ paint over it until you reach the bottom layer… alpha can be tricky if you let it get away from you… if you havent gone too far you might consider just re-painting the whole thing by removing the landscape layer, then putting it on again

It worked! I erased all layers on the bugged terrain segments, after that repainting them works fine. Thank you! :slight_smile:

very cool (smile)…