Landscape painting creates tons of base color texture files

So if you look at the picture below I originally created my landscape of just the section on the bottom right, with the building, trees, and pond. I later wanted to add on a new area and that’s the mountainous par at the top left. I went into the landscape tab, then to manage, and used the add tool to add more landscape area. I them sculpted it. However, once I gave it a texture and saved it, I got 99 base color textures files created in my game folder. Each labeled “Texture2d_[number]_BaseColor”. It did not do this with my original terrain so I’m wondering what this is and if I did something wrong.

seems to be a real bug…

Giving this question a “up” vote

Hi Alex8546,

  • What are the steps you used to reproduce this on your end?
  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

It seems to be limited to this project.
The steps:

  1. I created a landscape
  2. I sculpted the landscape, added procedural foliage, water, grass etc.
  3. I Used the add tool under the manage section of the landscape tab to add more terrain
  4. I Saved the project and then all those files appeared.

I can delete the textures and nothing in my project changes, but as soon as I save it again it adds them all back in.
I just now tried to recreate it with a new project and it didn’t do it. I have no idea what might be causing it.

Try fixing up redirectors in your content folder. To do so, go to your content browser, RMB the Content folder and press “Fix up Redirectors”. I’m not certain this will fix the error, however it is worthwhile eliminating it as a possible cause for the error you are seeing.

That didn’t help but I did find a way to get rid of the files. They were automatically created in the content folder. I moved them to a folder and saved it. The editor again added a bunch files to the content folder on save, however, they were all broken, missing the file reference (probably since I moved them to another folder). I then deleted the original set of texture files that I moved in the other folder and saved and restarted the project and the broken files were gone as well. Seems really odd.

Could you send me a copy of the project if you still have one with the additional files? I’ll be happy to take a look!

Unfortunately I don’t. After I"fixed" it I haven’t been able to replicate it.

I’m happy to hear this is no longer occurring for you. I’ll keep an eye out on my end for similar errors and if this does occur again please feel free to post back here with updated information. For now, I will mark this as answered for tracking purposes.

I am getting this problem.
When I import a height map to a Landscape it creates a ton of Texture_2D_xx_BaseColor files in the same folder as the level where the landscape was added.
If I change Material it says “Baking landscape material” and updates all the files with a new base color matching the new material. This is quite annoying. :slight_smile:

And not only that. If I remove these BaseColor files they will also remove the level in which the Landscape was created. Man… Lucky I didn’t try this in a level I worked a lot on.

Hi tsuzumi,

  • Are you importing through the World Browser or through the landscape modes window?
  • What are the exact steps you are taking to reproduce this on your end?
  • Are you applying a material during import or do you apply it after you have imported tot he editor?
  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • I am importing through the Landscape window.
  • I am just pressing create Landscape, doesn’t matter the settings.
  • I get the same problem if just creates an empty landscape, without any material.
  • It does not occur on a clean, blank project.
  • Try in a blank map, do you see the same error?
  • Is this limited to one map?
  • What engine version are you currently using?
  • I get it on all/any map, old or newly made clean or not.
  • 4.10.2
  • I just tried it on the 4.11 Preview, copying my project and still gets it.

I tried the previous posters solution, but it only works for that landscape and until I change the material(maybe other things would make it revert too)

I have not been able to reproduce this error on my end. Do you have a sample project or specific steps I can take to reproduce this error on my end?

Yeah, here is my project without any assets. I tried it and it still makes BaseTexture files upon Landscape creation → Level save.
And that is all I do to make it happen.

Hi everyone,

I was able to reproduce this on my end and have entered a bug report, UE-26890, to be assessed by the development staff.

Any clue to why this happens? And did you use the project I sent to “reproduce” this bug? If so, shouldn’t it be a setting problem as it persisted after I removed the content folder?

Unfortunately the only place I’ve been able to reproduce it has been in the sample project. I’m not certain what exactly is occurring at present.

I do believe I found the solution.
As mentioned in this problem.

“just disable in the project settings “Generate Landscape Realtime GI Data” and then you don’t even must restart your editor.”

Turning that off of course stops the engine from producing a ton of ‘Low resolution Base Color Textures for Landscape GI’…