Download

Landscape Paint tool causes black tiles on terrain

Hello fellow developers,

So I was trying out some things on the level design part, created a terrain + texture for it (from world machine).

Now my problem with it is that when placing the landscape material onto the terrain, it kinda nicely draws automaticly the mountains and grass planes, nearly like in world machine, but if I try to manually paint some parts over, these whole sections start to turn completly into that texture, and if I go over it with the second paint layer it turns black…

3: how it looks when I apply the material to the terrain.

  1. how it looks when i select the rock paint layer for example and start drawing, the whole section gets overriden with that texture.

  2. how it looks like when I know apply a second paint layer, for example grass. The whole section gets black. I can of course draw the texture over it, but then the purpose of the terrain texture from world machine is gone and I would need to redraw everything by hand…

I hope that someone has a solution for this. :slight_smile:

Also, not important right now, but my first attempt on a test terrain looked really good fitting, the rock and grass textures where exactly at the rights spots. with my overwroked terrain and the newly created masks, it looks like its pushed like 5-10m to the left. No Idea why its not fitting perfectly anymore, like with my first try. didnt do anything different really.

best regards

Probably some suggestion in this thread will help you: https://forums.unrealengine.com/showthread.php?4070-Landscape-painting-help&highlight=landscape :slight_smile:

Could you also post a picture of your material setup?

thanks for your fast reply. Unfortunately nothing has helped there. it seems that UE4 got a problem with pre-made terrain textures that come from world machine or so. Nor sure, but it always over rides the texture information on a section when trying to change just a mm in there.

having in there is a mask layer with world coordinates, the coordinates for the rock and grass textures and of course the blend layers.

why are you using no-weight blend setup in your -> paint tool -> target layers

can’t hardly see the pics on these forums, 22" monitor, lol. but looks like you have your layers in material set up right (make sure you have the weights set in the details tho)

and can’t see what all ya have hooked up to the left, altho a materials expert I am not. well, hope this might help a bit, maybe someone else can help with any other details.

btw: always save then build after changes in Editor, especially after major changes

This is a known bug that affects a certain bunch of people, you have to let all your landscape materials generate shaders first before painting and that will fix it

Thanks for your tips guys, but still no luck. I recompiled the shaders a lot, rebuild everything all the time but it still overwrites the section with the selected texture layer. its as if the information are stored in the layerInfo nodes, so as soon as I draw on the terrain that section gets the color information of that layerinfo, so it makes that whole section this selected color. When I now delete those layerinfo’s it goes back to before I started drawing manually, so the base terrain texture is there but the drawn parts are gone.

Here is another useful link: Why is the Landscape Paint Tool painting entire squares and not just in the brush? - UE4 AnswerHub -> take a look at the material setup that Ivailo posted or use “Landscape Layer Weight Nodes” instead of “Landscape Layer Blend Nodes” :slight_smile:

I am a master of this issue, as I suffered for nearly five days trying to fix. Here are some tips:

  1. Stacking order of layers seems to matter, especially when using alpha layers. Put all alpha layers on top. I started using just height blends because alphas were so buggy.
  2. Preview weight definitely matters. Make sure all your layers have a preview weight of .1 to 1. No idea why this is and it makes no sense.
  3. Always used weighted layer infos. Non weighted always, always break for me, if with alpha blend layers.
  4. Let things fully finish compiling before doing another layer paint.
  5. If you get black spots. Try painting over it with all your layers. One of them will guaranteed fix it, but some seem to have little or no effect.

Hope that helps! Just know you aren’t alone, but it does work, albeit in a really broken way.

this has happened to me in UDK and “build geometry” fixed it the few random times it occurred with me.

4 years on, and this just happened to me in Unreal 4.21.

I just followed a simple tutorial for the open world asset that ships with the game to set up a rock layer and a grass layer.

It worked last week, and this week when I go to pain, I get a black square. Pressing undo gives me an even larger black square.

The layer order as mentioned above did not matter, and “build geometry” did not matter either.

In this case you may have an issue with the layer blend mode of your landscape material’s base layer. If it’s set to weighted you can get black splotches. Setting your base layer to alpha should fix that.

Hello,
Juste passing by because I had a similar issue. The problem at mine was the layer blend info asset, I deleted the old ones and recreated them. Hope it can help :slight_smile: