Landscape Occlusion culling: Setting x/y bounds?

Dear [fill in your name here],

I’m currently having a problem where my landscape components get rendered just a tiny bit too late when moving the camera around a mesh on the x/y axes. It results in ugly flickering triangles of sky around the edges of the mesh when I move, which is something I’d like to avoid. My suspicion was that the bounds for the landscape components are set too narrow on the x and y axes, which I’ve checked with the r.VisualizeOccludedPrimitives command and indeed seems to be the case.

I’ve searched high and low, but it appears that setting bounds on the x and y axes is not possible for landscape components for some reason. Changing the negative and positive z bounds of the components did not change anything, as would be expected since the z axis is not the issue. Is there any way in which I could solve this problem, other than not using landscapes?

Yours sincerely,

I’m facing the same issue - have you found any solution yet?

Unfortunately I haven’t. For my current project I’ve chosen to use meshes instead of landscapes, even though that’s less ideal for what I want.

I do think that this is a functionality that should be implemented, as in the current state the landscapes can’t be used in combination with occlusion culling for third or first person games.


I’ve set the MaxLOD Level to 0 (I suppose i disabled the LOD for the landscape), and that weird flickering stopped.

I hope this may help you!

I have the exact same issue in 5.3
(Set LOD to 0 don’t fix it)

Any new solution ?

Disable Occlusion Culling