Landscape meshes with splines 'out of date', causing errors during Windows build

I have a world composition from 16 individual landscapes, each in their own levels that are generated. I’ve created a path using the landscape spline tool within the persistent level, that spans across 3 of these. And when ever I try to build the project for Windows 64-bit, I get these errors:

[2015.09.05-00.20.23:072][ 0]LogInit:Display: MapCheck:Error: Error Landscape_0 Meshes in output_x0_y0 out of date compared to landscape spline in Shikanze Rebuild landscape splines

[2015.09.05-00.20.23:073][ 0]LogInit:Display: MapCheck:Error: Error Landscape_0 Meshes in output_x1_y1 out of date compared to landscape spline in Shikanze Rebuild landscape splines

I’ve tried the following to try and get passed this, with no success:

  • Deforming landscape to all splines multiple times.
  • Open each individual level and re-save them.

Sometimes, it might have three errors, saying that all of the landscape meshes with spline paths on them are out of date, or only one, or two. Mostly a random pattern. I have a deadline of about 48 hours before this needs to be built so any help would be sincerely appreciated.

Any ideas? Is spline paths across several landscapes impossible in UE4?

I’ve also tried to load each level separately and of course, they look the exact same as when they are loaded in the main level. If I try to build the game with one of these landscape levels open, it will say that all three landscapes with the splines are out of date, and when I try building the game after opening a landscape level, then the main persistent level, it will say the level I have just opened is the only one out of date. If I click on deform landscape to all splines, forcing each level to be saved and updated, it will still say that only the output_x0_x0 is out of date. Any other ideas? I’m deep fried chicken if this isn’t working soon.

I’ve deleted every single landscape spline, and I’ve just painted a landscape material where the road used to be, and yet it says the landscape splines are out of date still, even though there are now 0, I have also deleted all of control points. I have opened each level and they have no landscape splines in them, as well as the main level.

Yes, exactly the same issue.

Some help on this one appreciated.

how does one ‘rebuild landscape splines’ ? am I missing the obvious…

I have the same error at 4.11 :

“MapCheck:Error: Error Landscape_0 Meshes in LandscapeMAP_x1_y1 out of date compared to landscape spline in Main Rebuild landscape splines”

Is there any solution for it ?

I know this is super old but was wondering if you ever found a solution. I’m having a similar issue and really would be out a bunch of work if I cant get this work again.

Hi, short answer - no unfortunately. This happened for a school project during my last year of high school, and due to the nature of assessment I could get away with just using a dirt landscape layer as the road without mesh splines.

Unfortunately my memory fails me on how I managed to at least stop the errors so I cant be of any help. Maybe try getting staff attention on the forums? I’m sure at least one of the UE4 devs would know this issue by now internally.

Try this as it worked for my build error.

Select the entire mesh after you can make it re-appear, then click on the “move to current level” button then click on the Deform Landscape to Splines: “All Splines” button, then rebuild level and error should disappear.

Nearly 4 years later this bug is still present, except moving to current level and deforming landscape again doesn’t fix it. Too bad epic is too busy ripping off dances for fortnite to be of any assistance. But they’ll gladly take a cut if you publish your game.

LOL. Four years is actually good for a bug at Epic. I don’t even bother reporting bugs anymore because they don’t care anyway.