Landscape material

Hello everyone,
I habe a big problem, and I hope someone can help me:
When I launch my game, unreal engine doesn’t find the landscape material, he said: failed to compile landscape material, and when I’m on my game, the material isn’t on the landscape.
Can someone help me, please?
(I’m on mac with osX yosemite).
Thank you for your answers!

Please, can someone help me?

Hello hellokitty01,

Are the textures for your materials -as well as your materials- present in the Content Browser? If not make sure they (the textures) are present and linked to the Material by opening the Materials and checking the texture nodes. Once you are sure your textures and materials are present, right click on the Content Browser and select “fix up redirectors in the folder.”

If that does not correct the issue, review setting up your landscape materials:

Landscape Quick Start Guide

Landscape Materials

-Steve H.

Thank you very much!

I do all like in the tutorial, but I just add an other texture, and when the game is compiling, it said:
Missing cached shader map for material, and after :Cmd: UpdateLandscapeEditorData, and :LogShaderCompilers:Warning: Failed to compile Material /Engine/EditorLandscapeResources/LandscapeLayerUsageMaterial.LandscapeLayerUsageMaterial for platform GLSL_ES2_WEBGL, Default Material will be used in game.

In game, just a little bit from the landscape will be paint…
How can I have all my landscape with color in game?

Thank you for your answers!

Nobody knows my problem?

Are you using the Binary/Launcher version of UE4 or are you downloading and compiling Source from Github? Is your project an all Blueprints project or does it include any C++ elements?

Also, with the Launcher and Editor closed try deleting the DerivedDataCache folder from the install directory and then reopen your project?

Please respond with the answers to the questions as well as whether or not deleting the DerivedDataCache folder resolved the issue.