Landscape Material problem

Update: I dug deeper into the problem and found out something interesting. In my landscape material I have material functions and inside those functions are all my textures parameters. The thing is that it has problem reading those texture parameters inside the material function. What I did was copied whatever was in the each of material functions and paste it directly into the Master material. After that everything was fine.

One image is with material functions.
This worked fine with 4.15 version and lower. Not with 4.16

The other image is extracted material functions and connected directly.

Seems a bit crowded, but now it works. Textures are not resetting anymore when engine is restarted

I just tested Landscape material in both 4.15 and 4.16 versions.
I created Material instance and applied few textures to it, then proceeded to paint on the landscape.
In both 4.15 and 4.16, painting was fine, everything looked great. The problem happened when exiting the engine and then starting engine again and opening the level. In 4.15, landscape kept the paint and textures, but on 4.16 version painted information was kept as well on the landscape but textures inside the landscape material instance were reseted to default.

Tested this on multiple machines, with multiple landscape materials, simple and complex.