Landscape Layers Importing Issue

I’ve been through a few sites and the doc pages on this, hoping for some insight on how to fix this.

I created some test images and a simple landscape to try importing in different orders, different materials, still not getting the result I expect. Each image was imported through the Target Layers panel by right clicking on the layer name.

Lot going on here to try and explain this issue, the black and white numbers are the maps. The viewport shows the result.

The material, I’ve tried different setups, the LB Weight Blend isn’t even in the docs for the Landscape Layer Blend, maybe its not even hooked up?

Finally, here is how I expected the terrain to look after importing 1, 2, 3 in that order.

I feel like I’m almost there, I just need the layers to stay in the order I imported them in or know what the correct order is.

Few things to note:

  • Not importing a layer on the first layer didn’t work either
  • Is my intended behavior even possible?
  • Can I also use texture height maps in my material? (we need better names for these things, the alpha map in the texture that determines the level of opacity)


Update- There still seems to be something I don’t understand about import layers- if I keep reimporting the second layer, each time it gets closer and closer to matching the mask. After about 10 reimports, I would say it’s a 90% blend. This can’t be the intended use?

Also, the Layer Info display seems buggy, sometimes when they are assigned the UI is not updated, you have to switch tools and come back to get them display properly.