Landscape Layers Didn't Survive Conversion to UE5

After converting a map from UE4.27 to UE5.03, the Landscape Material does not display properly. The Landscape Layer Info is not being used.

My Auto Landscape Material has 11 layers of weight and paint (worked fine in 4.27).

In Landscape Mode, the Layers do not register properly. The thumbnail spheres are the same whitish color that appears in the Landscape Material viewport, and on the actual landscape. What appears is simply a texture mix. The layer info is not being used. The mix on the spheres is expected, but not on the landscape.

I’m trying to assign layer info to each layer, but cannot. The dropdown does see the proper Layer Info, but selecting it has no effect. NOTE: there are additional, similarly named, Layer Info files shown in the dropdown – these are in other directories, and are used on other versions of the map. Again, this has not been a problem before, and I’m not sure it’s the problem now.

Does anyone have any suggestions or guidance on how to ensure the UE4 Landscape Layer Info is detected by UE5?


  1. From a review of the logs, the Shader Compilation stats look good.
  2. The Landscape Mode Layer list is complaining about the Painted Layers (‘No Weight-Blend’). This does not appear in 4.27. I tried assigning weight to these layers in the material. That Layer Info comes from the map, not the material.
  3. Clicking on the plus (‘+’) to Create New Layer Info has no result.