Landscape layer sample for grass

Hello all,

Does the Landscape Layer Sample node not work for anyone else?

I’ve done a landscape with splat maps with each layer named accordingly. The landscape material and layers are working just fine.

I’ve went into the main landscape material, which is each layer having it’s own material function for grass, rock, river bed etc. I added a grass output node and hooked it up to the Landscape Layer Sample node (which says weight for some reason even though that’s a separate node). In the parameters tab I typed the name of the layer I want the grass to appear on. But nothing happens. Tried the preview weights at both 0 an 1 and nada. And YES I did create a Landscape Grass type and did input the grass mesh I wanted to use.

I’ve done this before using a texture file for the layer in lieu of a Landscape Layer Sample node and it worked fine, so I’m familiar with the process etc. But cannot get the Landscape Layer Sample node to read/use the splat map. Again the names matched and case sensitive etc. Anyone have any ideas?

And for the record, I 'm not trying to manually paint on the grass, I need this to be procedural, so I DO need the layer sample node to work. Outputting a texture file each time and getting it to match was a pain the last time.


Some error here

A Boy and His Kite Demo, uses it at the landscape material, so if the demo works for the release, the node works. From what I know, there is no issue from UE4.17 up to UE4.22.