Landscape is invisible in "playing mode"

Hello. I have huge problem with my landscape. Everything works fine in viewport while editing, but it is invisible while playing. I was looking for solution, but I did not find any.

I know that landscape is still there in “play mode” because collisions still works. What may cause this problem?

Can you upload an image of the landscape details? If you click on the landscape in the world outliner, you should see it’s details. It sounds like you might have hidden the landscape in-game


Hi. I am 100% sure that it was unselected. I checked all options like this few times. But I solved this problem by reimporting my heightmap. It was good solution for me, because I just started to work with this landscape, and there was not much to rebuild. If someone has more details on their terrain, then it will probably not be an option.

Alright, glad to hear that you found a solution, however, I cannot tell you went wrong with the landscape, but lets hope that someone else a solution :slight_smile: