Landscape is Black

This is a little vague but I would first start with maybe recalculating the lighting? If you post a picture of the landscape and the material it’d give us a better picture as to what the problem is.

Hi guys, i hope u can help me… I set up a material for a Landscape with the unreal Docu but after i applied it my whole Landscape is black and i dont know how to fix it…

thanks for ur help ^^

Hi. An easy fix is to rightclick on your LayerInfo in the Paint section using the Landscape tool, there you will get an option to “Fill Layer”. It will fill the whole landscape with that material and should fix the problem! :slight_smile:

That is how my landscape looks like.

hi. have i to apply the Landscape to the layer at first? Because its nop working with ur tipp. I cant right click on it.

im sorry i tried it after i applied the layer to the Landscape and now it works but its a little bit too glossy. How can i fix that^^.

Feel free to mark my answer as solution so others can see it has been solved :slight_smile:

I don’t know about the glossyness, I’m sorry. Maybe use constants or add a specular map to the texture?

Hi Chamboo,

To address the glossy look of a material, try increasing the roughness closer to a value of 1.

I’m glad that this worked for @Chamboo. But I am trying to figure this out and the only thing that I can find in the last year is this answer and it does not work for me. I have spent 6 hours of my day trying to figure out why I can’t get a material to attach itself to my landscape. When I right click nothing happens. When I left click I only get 2 options; “Weight-blended Layer (Normal)” and “Non-Weight Blended Layer” I have migrated materials from the Sample content and they don’t work. I have followed the directions from the Landscape Quickstart guide and get the same results. What I am I missing?

I was just having the same issue. I figured out that you have to migrate the folder Landscapes_sharedassets from Content\ExampleContent from the Content Examples.

It has the layer info objects. Just put them in their spots and it’ll work out.

@bredanas Thanks for the reply. But now I have another issue. Migration from the Example Content project stops responding. I tried it 10 times doing a few things differently each time, but the editor just stops responding. I guess I’ll have to get that figured out then I can try this. Either way I appreciate your feedback.