Landscape is black using layerblend heightmap mode. help Please

Hi All,
I followed a bunch of tutorials exactly. It works fine in 4.12. But the land is not showing the material using heightmap layer blend.

I made a land_mat material. Made a layer blend 3 layers, heightmap option, .5 preview weight. attached the World Machine splatmap to the RGB heightmap pins, and then rock, grass, sand to the other pins. Included a LandscapeCoord node to scale right to 4033.

Applied to landscape, in paint saved the three layers as LM_heightweighted so can paint. Still after build it is black. I read to fill layer with color or paint to see something but that does not work properly. Is it bugged?

how about visibility mask? I put in a node for that nothing shows up either for that. Three days of tutorials later 13 hours a day no closer. Help appreciated thanks!!

this must be a HUGE issue for anyone importing splat maps. Nobody?

Not sure if you’re doing it correctly without seeing the setup. But landscape in 4.13 is bugged in case you’re on that version. Next update should address some landscape problems. There shouldn’t be anything wrong with using a splat map though. Post a picture of your material setup.

someone showed me another way, the layer height blend def. is bugged good to hear will be addressed you guys rock

What was the workaround? :slight_smile:

I hate it when people say solved and don’t say how so here it goes… but you still cant paint the landscape! he used mat layer blend adding in each layer with a new mat layer blend… I am too knew to describe it … but it is a masking and add thing. the painting stuff is still not working with that system…

I have not got a splat map to work with 4.13 yet. I did find this post but didn’t help much.