Landscape is alwyas invisible

Every time I make a landscape I apply the default grass material, and I can see it. but as soon as I attempt to re-open the map or the project the landscape is no longer visible to me. I can see it in the game if I hit play, but I cannot see it in the editor. And yes I have the landscape view turned on.

Hi Shotty,

Strange problem. I have a few troubleshooting ideas.

If you press ‘F’ after selecting your landscape, can you see it? (This is incase your camera is really far away for some reason)

And to be clear about “landscape view turned on” - I’m assuming you mean that “Show → Landscape is enabled”

I noticed you have some WorldPartition assets. Try opening your WorldPartition tab → Drag selecting all your cells → Load Selected Cells.

Let me know if that helps!

1 Like

loading the cells is what brought it back. So do I need to do that every time I open the project?

Cause I tried this a few times, create a landscape put the grass on it, reload the project and it was gone every time.

Glad to hear it!

I haven’t had a chance to dive into World Partition myself, but looking at ‘Window → World Partition → Data Layers Outliner’ there are options for ‘Is Initially Visible’ and ‘Is Initially loaded’

So putting your landscape in a datalayer set to load and set visible should work.

For an example: Valley of the Ancient content sample makes use of this new system.

1 Like