"Landscape has overlapping render components" error

I created a 6x6 tiles landscape in world composition, but kept getting the “landscape has overlapping render components” error. Deleting and replacing the buggy sub-level fixed it, but the problem just showed up somewhere else. Eventually I tired of it and decided to create i fresh from scratch, new engine version and smaller landscape/fewer tiles (5x5). The sub levels are simply named 01, 02, 03 and so on, no spaces or weird symbols. It all worked fine until I got to #21 - now #16 bugged out and then #17. I’ve searched the forum and answer hub, but the only “overlapping render components” questions I’ve been able to find, are World Machine related and I don’t use World Machine.

Anyone knows what’s going on, or anyone else having this problem? To me it seems to be a problem with imprecise snapping in world composition, but I have no idea what to do about it.

I noticed that next to the error message there is an option to “delete the duplicate” components and I thought lol, I’ve solved my own problem again just after posting a question (this makes me feel especially silly, because I only post questions as a last resort, after trying to solve the problem on my own for a least a few days). Apparently I did not - deleting the “overlapping components” deleted large parts of the landscape tile, that definitely do not overlap anything:

…so unreal seems to read components as overlapping when they are not. And what’s more interesting, it happened when I added tile 21 just like the previous time.

I created a landscape with only 4 sub levels, but large ones. It has worked so far. I plan to divide them into smaller levels later (in a copy of the project, to avoid messing up the project in case the same problem shows up again).

Has anyone been able to create a landscape with 20+ sub levels and not recieve this error? Or has anyone recieved this error, but solved it in a different way?

Hi broder_fisk

I have the same problem, 2019 here, are you still active? have you deal with this problem
can anyone share his expoiriancewith us ?
how to avoide:
[NewMapXX] has overlapping render components with LandscapeStreamingProxy_0

I don’t remember how I created my sub levels when I got that error, but now I create one landscape, and divide it into sub levels and it works. It’s fairly large so I don’t think the size causes the problem. I think you should avoid trying to move the sub levels around in world composition.

I am starting to get this error as well. I only started getting this error when I installed 4.26 preview5, which I uninstalled, and then tried to go back and work on some new projects back in 4.25.4. Not sure if installing and then uninstalling the preview caused this or not.

So, after playing around in the world composition, it seems that the LevelBounds for the first map, for some reason is doubling it’s size and won’t let you edit it so that is causing the issues.

Hey, I’m running into the same issue on 4.26. If I go into the sublevel I can see that the landscape proxy is duplicated right above where it should be and shows up in a checkered pattern. If I delete the duplicate from the map check window it looks like the issue’s fixed. I can reset the scale of the LevelBounds and it fits right where it should, but if I return to the persistent level and load the sublevel again half of the sublevel was just removed instead. I’ve tried to recreate the affected sublevels but this issue pops up again. It’s always in the 6th column of tiles out of 27 for me. Each tile is only 125 square meters. I’ve made the whole world before with 375x375 meter tiles with no issues but I’m just trying to scale down each tile size.

I am having the same issue, is this a bug or a mistake I am making.

Try to disable, Enable Edit Layers in Landscape details panel