Landscape Grass Type is not properly spawned before grass.FlushCache. And then only the grass in the scope is corrected

I have created a landscape material whose grass type is like this:

330060-grasstype.png

The problem is that landscape grass types are not correctly spawned on the landscape. If I command grass.FlushCache, the zoomed part of the landscape in the scope is correctly spawned again. However landscape grass types far away are still incorrect. When I find them and command grass.FlushCache again, they are corrected too since they are in the scope at that time. Still other places were not in the scope before grass.FlushCache was called yet, and I have to iterate all over the map to correctly spawn landscape grass types everywhere.

I have tried to build everything, restart engine, package the project (hoping it is editor issue and the standalone project would work fine). The result is the same.

Is this a bug, or am i doing something wrong?

Nobody can help?

I found the answer. It happens when you do not set the grass type of any layer in the grass output node settings.

Those layers did not have grass types. So I did not expect the engine to get confused of the grass type layers I set.

“Never leave any grass node layer, its grass type unset. If you do not need a layer, remove it.”

Nevertheless, engine should have handled this without problem. A bug / improvement request maybe.