Landscape Grass Sequencer Animation Issue

Hey all,

This is a super specific issue but its driving me crazy. When I use large landscapes with the landscape grass tool, and when I render my animation sequences using the movie render queue tool, i think the grass is trying to populate throughout the whole map. None of my grass or foliage scaleability settings are being respected. My Ram usage jumps up to 64 GB almost instantly, when the same PIE session takes about 10 and runs smooth as butter. Ive tested on smaller landscapes in otherwise empty levels, and been able to get a render out, with Landscape Grass, but i notice that it still extends far far into the distance, like its never being culled.

Ive checked the materials, the foliage placement tool and regular static meshes do fine, its just landscape grass.

Posting this here as a Hail Mary in case anyone else has run into this :frowning:


well, chances are your grass definition uses the default cull values?

Why not set them manually to values that make sense for recording?
Not positive that will completely solve the issue, but it is likely where you need to play in order to get it right.

Sequencer usually should render at cinematic quality level. The distance on that could need to be properly manually set.

Haven’t tried rendering a sequence in a long while though, so while that could be it it could also be no help.

Hi, thanks for your reply!

Ive tried setting the cull distances in so many ways.

Here’s what I’ve tried.

Individual mesh cull distances inside the landscape grass type, they are around 10 meters right now, this works in in editor, in “game” but no effect in sequencer (4.25 Movie Render Queue to be specific)

the following console commands

grass.culldistancescale Default is 1, when I put it to 10, as expected in the editor, the grass extends much further than before, when I put it below 1, it pulls back. Seems to have no effect in the cinematic recording

grass.densityScale Default is 1, This has effect in both editor and cinematic. But it simply makes the grass splotchy, but in the cinematic it still extends into infinity

played with the scaleability settings for view distance and foliage.

They all affect both the static mesh foliage and any static meshes in the scene, but not the grass. If I put grass to low, density becomes 0 and then it renders perfectly, but theres not grass.

I might try starting a new project :S

Started a new project, no luck. Maybe its a bug? It only happens in the movie record mode thats new in 4.25

I put density to like 3 and 6 uu, still makes no difference

Found this thread but didnt really know if it was the same thing, his problem wasnt just happening in sequencer

My conclusion is that it has to be a bug. I just tested it using the old method of rendering sequencer, directly from the sequence player, and grass culling is working, render is smooth as butter.
play in editor works fine. Movie Render Queue just seems to attempt to populate the entire map with grass no matter what. I didn’t notice it on my smaller maps, but on larger ones, it crashes. I tried changing the movie render game mode, still no luck.

Ill just do some manual grass painting i guess!

Makes sense. I wonder if its working as intended or a bug. Usually for cinematics you really do want to render all the grass (provided its not occluded ofc).

I would suggest you make a bug report on it either way.

FWIW, This is still a thing in 4.27.1.

I get that most people aren’t going to want the nasty “popping” effect you get as you load foliage elements on the edge of a culling distance, but why not give us the choice? An extended culling distance with almost invisible popping is still preferable to crashing or OOM fails due to loading a massive landscape full of LOD0 foliage.

Procedural grass/foliage is designed as an alternative to having to paint foliage over a huge landscape, so it’s kinduva bummer that you HAVE paint it if you have a big landscape and want to use MRQ. I guess an alternative would be a procedural landscape spawner volume, but I haven’t figured out how to get it to spawn as densely as the landscape grass tool. Seems more suited to random bunches than carpeting.

You can just use better tools to create the scene - while that can also mean not unreal, hint hint - what I really mean is that if you enable, setup, and properly use the procedural foliage tools you can fill a whole landacpae with grass instantly and have it also not cull/work at it differently.

The landscape grass, in the end, is a nice thing to have if you use Landscapes a lot.
However it’s really anything but necessary.

Mapping it to certain areas without a landscape can be tricky.
Top suggestion is to procedurally create no Spawn zones (procedural blocking volume) based on an alpha map of some kind.

Also, the foliage tool has a “fill” function that will fill the whole landscape or whatever else.

I don’t think it does without a specific setup, but you should be able to use an Alpha as the brush to paint with.
Meaning you can set the brush up to covet the whole mesh, apply an alpha mask, and clock to have it paint in only where the alpha says to paint…

Hey guys,
I am using the grass node in my landscape material to make my procedure forest and grass and can not render out using move render queue.
The solution i found was crank up your render warmup and the scence will render the instance grass.
Hope this help you.

1 Like

Still having this ridiculous issue in UE 5 2.1 in 2023 - has no one found a work around in all these versions. Makes Landscape grass virtually unusable for my project.