Landscape Grass Causes Ghosting

I have a material that makes (attempts to) make use of the LandscapeGrass node. However, as you can see, if I move it leaves behind a ghost effect. Is there a way to disable this? It makes it challenging to see clearly.

This only appears over the grass effect on the landscape, into the distance there is no ghosting at all.

Can you post a screenshot of your material setup?

Absolutely. Let me know if you need anything specific. It essentially auto textures my terrain based on elevation and the steepness of it. The first picture is repeated several times over to hook up each layer.

On the left side of your very first screenshot is that also a problem effect of the material? Looks like it is blurring out or adding noise to the left side from the edge in to about 15% of the image on the left (Almost looks like a fingerprint on the camera lens).

That’s what happens the foliage is coming into the camera. It gets all fuzzy.

If that is also part of the problem it seems that something in the World_Aligned_Blend settings is causing the issue. Would you mind sharing the material so I can take a closer look?

I can share it. What’s the best way to do that? Also, this world aligned blend is provided via UE, I didn’t do anything for it.

Dropbox, googledrive etc any of those file sharing platforms should work pretty easy and then just post a link. I meant the values going in and coming out which is why I would like to take a closer look to see what can be adjusted to keep the desired look without the weird behavior.

Lets try this.

This turned out to be a Temporal AA issue. This is how we ended up coming to the conclusion and this is how it was fixed:

" Do you have a post process volume in the level? If not add one to the scene and go through the settings or search for “motion blur” check the box for amount and set it to “0” and then do a search for Anit-Aliasing Method (or AA Method) check its box and set its value to None"

To further make the scene look better this command was used to sharpen up edges:

"Run this command from the console: r.ScreenPercentage 200 "