Download

Landscape disapears when playing level

I created a level and spent a lot of time painting the landscape, But when I click play it’s not being rendered?
Hide actor in game is not set so that’s not the issue.
I can clearly see in the wireframe view when playing that the mesh is also not visible But I am also clearly walking on it as I move across the terrain.
I have tried to migrate the map to a new project But it had the same issue.
I also rebuilt the lighting, Made no difference.
pressing alt +L in game dosen’t work, only in editor.
I read that resampling the landscape can help But in 4.25 there don’t seem to be any options to do that anymore :((( Only options in manage seem to be import new map.
Really not sure what the hell is happening here :frowning:

Well, export the hightmap from the level and import it into a new one.
You can then hook up the same paint layers instead of creating new ones to get back to the exact same thing you had.

As far as the issue goes, if you arent seeing the wireframe the landacape is definitely set not to render. That doesn’t disable its collision necessarily…

Thanks.
I Followed your advice. I positioned in new landscape exactly to the location of the old one. And once I figured out how to reactivate the Landscape layers on the new one, It worked :slight_smile:
I deleted the old one as I believe it must have become corrupted.