Download

Landscape culling bug?!? Please help!

EDIT: Check last post please!

Hey guys!

I followed the ue4 grass tutorial: https://docs.unrealengine.com/latest/INT/Engine/OpenWorldTools/Grass/QuickStart/index.html

But i ran into some problems with the start/end culling variables. Here are some screenshots of the issue

terrain_grass.JPG

as you can see, the grass render distance is very short/close.

Here are the start/end culling settings:

foliage_grass_editor.JPG

and the material Editor:

material_editor.JPG

CHANGING THE START/END CULL DISTANCE Variables wont do anything… i can only make the cull radius shorter, not longer

Any ideas what could causing that problem? Btw. im using epics assets… so i assume everything is fine with the meshes

Thanks for your time :).

bump…

Please try to wait 4 days in-between bumps. As for your question, your picture does appear to be low quality, what are your engine scalability settings? If they are not set to Epic, try to change them to that. The view distance/foliage settings might be playing a role in the short-distance culling.

i checked the scalability settings, everything was at “epic”. so i guess its not the reason for this issue, but thanks for your tip :).

So i´ve checked if the start and end culling Options have any effects if i turn on wireframe mode and it does. In wireframe the grass is culling correctly. Here are two screenshots:

wireframe2.JPG
wireframe3.JPG

So the wireframe is rendered, but the actuall mesh not… seems like it must come from some LOD settings? hopefully this helps someone to understand what could cause this problem.

Just thinking out loud here, but isn’t the Min LOD supposed to be 0?

i already changed it to different values, but nothing affect really the texture render. I try now to reintall 4.8.3 and see if that helps and also check if the same bug appears in 4.9

The only thing i´ve also noticed was that if i disconnect the texture in the material editor, the meshes of the grass (Little squares without textures on it) will render correctly with the cull settings.

Otherwise i report it to epic, because this seems to be a hardware bug to me… (if they didnt saw already the thread by themselves)

I will assist you with this issue in your post found here](Culling Bug? - UE4 AnswerHub)

Regards,

Andrew Hurley