Landscape Component NOT saving


My team and I are creating a semi large game with a large landscape actor.

After countless hours trying to fix a single component in the terrain, it still wont fix itself. The problem with is that (first of all), the terrain collision did not match up with the terrain being rendered. So try and fix it, we simply smoothed out part of the terrain, assuming that this would rebuild that component, and yes, it did fix it. However, when we reopened the project, we found that the single component did not save. You could go and edit another component of the landscape, save it, and reopen the project, but this single one would not save or update. I even tried completely deleting the terrain component, saving, reopening, and it was still there.

We tried multiple fixes, from deleting the component and re-adding it, to deleting it and undoing, to also duplicating the landscape and deleting the old one. All of these work, right up until you reopen the project itself. Then you will find that this simple still did not save.

Is there anyway to fix this? It’s a huge problem since were trying to work on this area of the level.

Well, we managed to fix it. Seems like a combination of duplicating the terrain, rebuilding both lighting and geometry did the fix and allowed it to be saved.

Assuming this is a bug!!

Edit: We noticed that duplicating the terrain makes it so the foliage is not copied over, therefore this is not really working. Any help would still be appreciated.

I also had this bug, however it also occurs now in a new level, this is permanent and also causes a crash for me every-time the map tries to autosave