Landscape Collison Issues (RecreateLandscapeCollision doens't solve it)

Actually, the bug solved in 4.3 is back. The landscapes created in 4.6 (using WorldComposition) have a issue with their collisions. “RecreateLandscapeCollision” change the collisions but they are still incorrect (like a mountain in a plain and vice versa).

Not sure if this is the exact same issue but I am running into a similar issue where it seems like certain tiles (blocks) of the landscape have no collision on them. This is terrain that worked perfectly fine in 4.6 and prior but now has random collision issues in 4.7.2

I’ve checked the collision thickness and its set at 32 like all the rest of the terrain in the level. Just seems like random tiles of the landscape now have missing collisions or incorrect collisions. (And its not just a seam you fall through. Its the entire tile of the terrain that has no collision)

Hi everyone,

While I was unable to reproduce this error on my end, we have had a number of users experience this collision bug. I went ahead and put in a bug report, UE-11447 to be assessed by the development staff. Can you try the workaround suggested below and see if that fixes your error:

It doesn’t work. The collisions are still offset. I even try to resample to a higher or lower resolution and the landscapes disappears. I’ll recreate my 64km² hand painted landscape. Marvelous.

The collision are good in each sub-level but in the main level using World Composition, the collision are offset. To create a new main level doens’t correct the issue.

Hi, would it be possible to attach here project where you see this issue? You can strip all the content we need only maps with landscape actors where we can reproduce this.

This is the link to gete the incriminating levels: https://www…com/sh/ydqi375eu3c0qbp/AACLOz19bM2k4zivVO6xHuJLa?dl=0

Thank you for the updated information, I will add this to the bug report I entered above.

We fixed the bug in 4.7 where collision for landscape components containing XY offset data (generated by the Retopologize tool) was broken. The fix will be in 4.7.3 which should be out next week. If you’re using source code you can apply the fix directly before then if you’d like: