Landscape collision seems to be offset when making holes with Landscape Visibility?

When working on the Landscape in the Current version of Unreal. 4.13.1, I noticed an odd offset with Landscape Collision and the holes made with the Landscape Visibility tool.

It’s more noticeable with smaller holes made, but it would appear that the collision made is partially offset from the actual hole displayed on the Landscape. (see pic below)

Now, i’m not a pro at the new landscape tool, but is this a possible bug? Because of this, I can shoot or fall through visible terrain on one side, while i can collide/stand on and have shots blocked by invisible terrain on the other.

Hey Jaysinsan,

I am not getting the same results in a blank 4.13.1 project using a simple landscape visibility mask and vector 3 for the base color input.

Are you using World Position Offset or Displacement in your Landscape’s material? There are settings within the Landscape details panel under collision that could be causing this issue to occur.


Can you provide me with a screenshot of your material and some simple steps so I can get your issue to occur on my end?

Thank you,

Sure thing, give me a sec and i’ll get you more info!

Hey Jaysinsan,

Have you been able to narrow down a repro case to provide to me so I can get the issue to occur on my end?

This ticket will be marked as resolved for tracking purposes until you respond with the necessary information to continue troubleshooting.

Thank you,


I thought I did, and submitted, but apparently that didn’t go through.

My apologies, I’ll try to re-submit that info.


  1. Create a new ‘default’ map that at least allows you to spawn in
  2. Create a new Landscape terrain (i shrank my section size to 7x7 quads just to make it a tad smaller)
  3. When ‘creating’ the landscape, it’s not necessary to apply a terrain material to it just yet.
  4. Find and edit the default material “M_Ground_Grass” to make it accept a Landscape Visbility Mask node.
    4b. to do this, change its “Blend Mode” to ‘Masked’, then add the Landscape Visibility Mask, and attach it to the Opacity Mask input of the Main Material Node?
  5. once finished, and saved, assign the newly edited Material to the Landscape
  6. Edit the landscape’s visibility now, and create a small hole or channel, roughly say, 32 units wide, and another that’s roughly 64 units wide.
  7. Now, play in PIE, and shoot at the holes.
  8. Notice, that along the Y Axis, the collision seems to be offset by 16 units.
    8b. this means you can shoot into the terrain along one side, and then shots bounce off invisible collision along the other side of the hole.
  9. Now, walk along the edges and observe how you can either fall through or not, depending on which side of the hole.

See attached pics for settings of things

Hey Jaysinsan,

Thanks for the clear and precise repro steps. I was able to confirm what you are reporting and have gone ahead and entered a bug report for the issue. You can track the issue following the link below on our public issues tracker.


Once the issue has been addressed by our engineers either myself or another staff member will return with an update.

Let me know if you have further questions or need additional assistance.


Still no news on that? Same issue.

All the information I can give you is already in the bug report link. The target fix is for 4.17 as of late.


Simply to let you know that the bug was fixed and should make it for 4.18.

I just checked in 4.19 beta and the issue still persists.

Currently getting this on 4.21

I know this is a super old thread and the reported issue hasn’t been resolved. But have you tried adjusting the Collision Mip Level for the landscape? The higher the collision mip, the lower resolution of of collision and nav will build on it.