Download

Landscape chunks on black on mobile

Hi,
I’ve been trying to get landscapes to display correctly on mobile but have hit a problem I’ve been trying to get around for a while now. So i threw together a smaller test project to test.

I get what appears to be random tiles/chunks just being solid black when running on mobile. I’ve included a screenshot below.
Strangely enough, when I first ran the scene using the mobile preview the same chunks while not solid black, were very dark. I found some other threads that suggested painting all the terrain sections with each layer then go back over it how I want it. After doing that the mobile preview came good, however it was still bad running on the device.

I also created a copy of my project, and it seemed that I got different terrain chunks showing black.

Has anyone experienced this before? Have any ideas what I can look into?

Update:: Just as I was writing this, I also tried to export rather than using the “launch on device” and those same chunks now show a solid texture, but it’s not what should be displayed.

This is what it should look like: Running in the mobile-preview on PC.
7a8ee6a0723ec9bf1e6fe39f1c7061aeeb544a77.jpeg

This is it using the launch on device, showing the solid black tiles.

This is after packaging showing the solid textures.

Can you open an answerhub ticket for this? That way we can get support to look into it.

Hey RCaloca… Sorry I should have put an update here but I did put an answerhub post up here: Landscape Chunks Black with 4.7 on Mobile - UE4 AnswerHub
Rudy has reproduced the issue and raised report UE-12441 in relation to this issue.

I have also this bug.

Hi kodmistrz,

This issue has been fixed for the upcoming 4.8 release. Looking at when it was integrated, it may even have been fixed in the 4.8 preview 2 release, if you don’t care to wait until the official. But there are some other Android issues that won’t be fixed until the official release that might hamper development, depending on what you’re working on.

Yes, it looks fixed in preview 2. I tried with preview 1, was still an issue, updated last night to preview 2 and it seems fixed.