Landscape chunks left without texture

Simply when adding normals to the Landscape Material, the landscape will end with some “Dead Texture Chunks” or whatever you wish to call it. The point is, that the landscape has those “patches”:

In previous versions of the same Material it worked fine, but the material was a little bit less complex (Two layers less).
This is the Material:

You can imagine the Normals part, is the same, but **the output is multiplied by 5 **, I don’t know if it can affect.

They use the exact same node configuration, both diffuse and normals. So, how it can be fixed? What is causing this? The shader compiles without aparent errors.

PD: The landscape is tiled, created with world composition and the weight data for the layers is given by few World Machine tiled renders.

Hey SigmaSoldi3r,

You mentioned this worked as expected prior, but this material has a couple of extra layers now. I would try setting your texture samples to Shared: Wrap to see if that resolves the issue. There is a known limitation with DirectX which does not allow you to exceed a certain number of texture samples. I believe the number is 13 unique texture samples, but as soon as you set your samples to Shared: Wrap, you are able to use unique textures.

Hopefully this resolves your issue, but let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Perfect!!! Many thanks!! It worked! I didn’t know about this limit of 13 samplers.
Thanks, really!