Landscape/Character Collision issue

Hello everyone. I started working on my project on Unreal Engine 4.9. And recently updated it to 4.11. As the title says, I’ve now ran into a problem with the landscape collision, similar to what was happening on version <4.3. And for those who don’t know, it’s when you create a slope on your landscape with a smooth tool or retopologize tool and when you try to walk on that slope with the character, it falls through the landscape on that spot. For me this happened with the smooth tool.

I tried a few workarounds to fix this that I found from the internet, like ie.

  1. Resampling the landscape from the Landscape → Manage → Change Component Size

2. Then I tried to use the Flatten tool from Landscape → Sculpt → Flatten, to fix the broken area, but that didn’t work.
3. And finally I tried to change the smooth tools settings to and reapply them to the scene but it did not work either.

The resampling of the landscape did work for the first time, but as soon as I made a change to the same area using the sculpt tool, the issue came back and this time resampling the landscape again did not work. I have absolutely no clue to what causes this and I’ve been hesitant to use any user made addons to try and fix this.

Here you can see what the spot looks like where the character falls through.

The area around the picture works perfectly fine even though it is made using the same settings on the smooth tool.

If there’s anything else that I can provide, I’d be happy to do that.

Update regarding the issue: It seems like I’ve been able to fix the issue once again by following the step nr.1. Once I apply the resampling process and the landscape turns kind of pale color, I save and quit the UE. Once I open it again, it fixes the pale effect away and the collision is working again. I won’t mark this question as solved as I can simply reproduce the issue.

Hi Mechlul,

Unfortunately, I have not been able to reproduce this on my end thus far.

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this error on my end?
  • Are you using a landscape created in editor or is it an imported heightmap?

Hello ,

I created a new clean, blank project and was unable to reproduce this issue no matter what, which seems to point the finger to my main project.
On my project where this occurs it seems like all I have to do to break the collision again on that specific spot, is to paint a new texture over it.
The landscape was made in the editor and was created on version 4.9 and imported to 4.11.

Would you like me to send you the part of the landscape that is broken or is there some sort of debug tool where I could provide some additional information?

Kind regards,

If you feel comfortable with it, can you provide the landscape map with the material in question? I may be able to see what is occurring.

I will duplicate the project now and delete everything that’s unnecessary to keep the size small. Is there some place I can upload it to or shall I clean my dropbox?

Hello ,

I’ve now packed the project into the smallest possible size and even tried to point you in the right direction by setting up a widget that shows you where the issue is present. Hopefully you’ll find something useful regarding the issue from this! Good luck. :slight_smile: Dropbox - File Deleted - Simplify your life

Hi Mechlul,

While I was not able to reproduce it on my end in a clean project, it clearly reproduces in the project sent. Unfortunately, I’m not certain what is occurring, but I have entered a bug report, UE-30032, to be assessed by the development staff. In the mean time, it would be best to use the Resampling feature frequently to ensure collision is maintained on your landscape while you work as a workaround until a fix can be implemented.

Hey ,

Thank you for that and hopefully they can find what’s wrong with the collision! :slight_smile:


I have examined the example project, and the issue is that you used the “visibility” tool, without having your material set-up for it. This is designed to cut holes in the landscape, both visibly and in the collision. Without the material being set-up, it ends up only cutting the collision.

If you add a “Landscape Visibility Mask” node to your material, and connect it to the (disabled, but that’s fine) “opacity mask” output, you’ll be able to see your hole :slight_smile:

I’m going to see if I can add some hints/tips to the visibility tool about this, and maybe disable it altogether if you don’t have a Visibility Mask node in your material.

How comes the resampling process did fix it until I made a change to the scene?

But anyways, there are no words enough to thank you both for your awesome and quick help. I was literally struggling with this for a good amount of time! But like you said, some hints/tips would really be a nice addition to the visibility tool now after this incident. :smiley:

The more odd question remains when and why did I even use the tool in the first place… Maybe I’ll just blame it on the cats.

But really, thank you both and till next time! :stuck_out_tongue: