Landscape brush not showing

When I assign the desert material created by Epik to my landscape, the sculpt brush disappears. Does anyone know how to fix this?

hey man, i have a similar problem as you, its the thread below, check it out it may help and you may be able to help me :slight_smile:

-check if you are still “in” the right landscape -> on the top of the landscape editor you probably see a dropdown bar where you can choose a landscape
-check if you are in the right streaming level (when you use level streaming)
-increase the size of the brush and try it again
-what happens when you just presst ctrl+left mouse button + move the mouse
-which engine version? (so that I can test it) :slight_smile:

I am on 4.25 and have the same problem…I can not see the brush on the viewport…any solution?
If I click I can paint with materials or sculpt, but as I do not see the brush, it is kind of annoying

Same no answer still

I am also having this issue, and I would like to be very clear about the specifics I have gone through just to make sure people understand that this is a real issue:

  1. Yesterday I was working on a Landscape, made an auto material, and sculpted out some mountains and used layers to make a spline layer for paths.
  2. I opened my project this morning, removed my Landscape Material, added a layered blend to it so I can paint over the auto layer with snow, and when I go back in to paint I do not see the circle on the Landscape.
  3. I tried creating a new Landscape, and the circle does appear on that one when I attempt to sculpt or paint, but switching back to the first one, even after completely deleting the new one, I do not see a circle on the initial Landscape.
  4. I have tried changing the radius and other options on the Landscape, and nothing seems to bring it back.

I have tried opening a new map and going back, I have tried closing and re-opening the project. I can still paint and sculpt the Landscape as I should be able to, but there is no visual circle on the Landscape. Is there some boolean on these Landscapes or something that toggles the cursor visibility? It would be nice to get a conclusion to this problem…

Edit: I have even went and tested Landscapes in other maps, all of them show the circle as they should. It is JUST this one Landscape that isn’t and unfortunately for me it’s the only Landscape in my project I need… This is actually infuriating.

Edit 2: I just had it happen again with another Landscape. It happened after applying Edit Layers to a pre-existing Landscape.

I’ve also had this issue, I however did not have Edit Layers enabled, it was only shortly after creating a landscape. I’m not sure at all what has caused it but I cannot for the life of me figure it out.

Just ran into the same problem in 4.26 and was struggling to find any answers in the forum.

What fixed it for me was disabling ‘Enable Edit Layers’ in the Landscape details and enabling it again. Seems like a bug. Hope it’s not too late and that it fixes it for you too.

1 Like

Just ran into this problem but the “Enable Edit Layers” trick didn’t work for me =(
Also tried clearing/resetting project settings

Any other suggestions?

Had the same issue just now. I had raytracing enabled and I disabled it in the project settings which seems to “fix” it. Might also be that it just needed a fresh recompilation of the shaders to display the brush again.

TLDR: Disable the “ray tracing translucency” in your post process to get the brush back. Re-enable it when done with editing.

I ran into this issue as well. So I ran a few tests.
1.) Created a project with RT enabled and without RT enabled.
Both projects showed the brush in landscape editing mode.

2.) Searched for the asset that the gizmo uses by searching “engine content” with the filter “brush”.
Found that it uses “CircleBrushMaterial” as the asset. Digging deeper, it seems to behave like a
decal using translucency. This suggests that the Ray Tracing is causing an issue with the
translucency.

3.) Went back to the problem project, and created a new level. (no special lighting or post processes)
The brush appears in the landscape editing mode. So…it can’t be engine or project settings.

4.) Opened the problem level…“cut” the post process out of the scene. The brush came back in full glory.

5.) Dug deeper into the post process, and disabled “ray traced translucency”. Brush is working as intended now.

While making edits, I can disable the RT translucency, then re-enable when I’m done. Not a big problem. Just slightly annoying.

2 Likes

Maybe this is too obvious, but what worked for me was to add the plug-in described in this link.

after following the steps described I was able to see the brushes in the project.

I hope it helps.