Download

Landmass Plugin - Paint Weight Bug with Blueprint Brush?

Hello there,

I experience strange behaviour with the Landmass Plugin when I want to paint a certain color with a brush. The green colored layer is populating the landscape with grass (set in the material). Expected behaviour: Only grass where I have green color, every other color should mask out green color and delete grass.

on the left side, the pink color is painted with a landmass blueprint brush. it should basically mask out the green color and do NOT draw any grass. the right version of the pink stripe is hand painted which behaves like expected.

the landmass brush does seem to blend in with the other layers. layer order does not effect anything, adding layers in the new layer system does not effect his behavour either.

anyone can reproduce this?

Hi Jwtrp, i just started using the landmass tool to block out my landscape and i m expecting the same behavior in 4.24.3 . The textures of our landscape just dont’ blend correctly causing issues like grass spawning also on the rock textures. Did you found any solution to this issue?

Heya,

I’m getting the same issue.

I’ve been trying to follow this demo

But every time I add a paint layer target the info is blending with the layer below.

Does anyone have a fix??

I will start another investigation in the next days regarding that issue. But it is interesting, that more people come up with the same problem.

I am definitely having the exact same issue. Interested to see what the answer is

I have same issue i was trying all blend types, in weight blending textures are like on JMW90 picture, when alpha blending i get good texture output but, when i add any grass and landscape is filled with grass material it also spawn foliage on mountains and other materials, anyone know solution how to fix that?

I have the same exact issue - Grass seem to blend with Rock instead of Rock replacing Grass on Blueprint Brush like in demo.

I played around with a bunch of different settings, but so far the only trick that sort of fixed the issue is in “Edit Layers” tab to set Layer Alpha to something very small like 0.01

This way Grass still grows there on the rock but not as much and Grass blending with Rock is pretty much invisible.

What I noticed is that in LandmassBrush settings (on the bottom) “Affect Weightmap” mark isn’t working.

Which seem to point to the root of the issue - Blueprint brushes don’t affect weightmaps.

Epic is using non-weighted landscape layers to keep the value below, seems to fix when switching to that

Can you describe how to fix that? I’m having the same problem and I can’t figure it out.

The layer blending needs to be changed from Weight Blend to Alpha Blend

In your Landscape Material, set the Blend Type to LB Alpha Blend for all the affected layers
In the Landscape Edit Mode, create Layer Info of the Non Weight-Blended Layer type for all the affected layers (if you have already created the later info, open the “XXX_LayerInfo” Landscape Layer Asset and enable the No Weight Blend checkbox)

In the following video (at the 1 hour 14 min mark) you can see Paulo is using the setup I just tried to describe:

My understanding is using the Blueprint Brushes to paint Landscape Material Players is analogous to manually painting Landscape Material Layers on separate Edit Layers. If the Material Layers are set to Weight Blend and painted on separate Edit Layers, they will each get a 50% share of the blend weight and you will see both of them blended together. If Weight Blended Landscape Material Layers are painted in the same Edit Layer, one can have up to 100% of the weight causing only it to be visible and the other to disappear.

The solution to both of these issues is using Alpha Blend in conjunction with the Non Weight-Blended Layer type.

If you need a visual explanation of what I just said, watch this video: