Keyboard Shortcuts not working in the Unreal Editor

Hi,

I recently installed the UE4 4.11.2 on my laptop, and I seem to have run into an issue where the Keyboard shortcuts in the editor won’t work (i.e. M+Left click to add the Multiply node in the Material Editor doesn’t work).

I have checked the editor preference in edit-> editor preference and made sure that the keybindings are set to the default, yet the problem has not been solved.

The only thing I could note was that pressing the shortcut key the stops the mouse from moving.

I have tried several searches but couldn’t find one that ran into my issue. Has anyone run into this issue? And what do you think could help in fixing it?

Thanks for going through the post

There is a thread on the forums that I posted but no had an answer to it yet [link text][1]

[1]: Help, Keyboard Shortcuts not working in the Unreal Editor :( - General Discussion - Unreal Engine Forums(

Hi Yousef,

I’m not seeing the same thing on my end when testing in 4.11.2/4.12 on my Desktop build, a Mac Build, or even on our Razor Laptop build.

If M+Left Click is freezing your mouse make sure that there isn’t any other programs that may be affecting your mouse shortcuts as well.

Can you provide the following:

  • DxDiag
  • Your Laptop model number
  • whether you’re using the touchpad mouse or a plugged in USB mouse.

We may have a comparable laptop here to test, but from the sound of it you have another program that is likely using a similar shortcut that may be interfering so you may want to disable any programs that are typically installed and running by default on the laptop to verify this.

Thank you!

Tim

Hi,
Sorry for getting way back at you way late I have gotten the DxDiag file link.

The Laptop is an Alienware 17 R3, and the problem occurs on both the touchpad and Mouse. It seems that the problem mostly occurs when I am connected to the internet.

I’m not able to reproduce this issue that I can see on a Mac laptop or on one of our Razor laptops.

You may want to make sure that the correct GPU is being used when you test though because in the DxDiag it was showing that the Intel HD Graphics 530 was being used instead of the Nvidia GPU that is listed on Alienwares site.

You may want to see if it’s not something with the trackpad for the mouse by using a wireless usb mouse or wired mouse.

I have verified that the GPU being used is the GTX980m, I also tried a wired mouse and a bluetooth mouse and I still had that same issue.

I think the issue is not really with the Unreal Engine but the problem is with my Machine, is you said the issue might come from the shortcut options that come shipped with the laptop.

Will investigate on my side also…

Hi yousefbuhazza, there is no problem with your machine. For any shortcut, for example
1+left click for constant node, you have to press Fn +1+left click. It will definitely work.
Even I had the same issue. I found the solution today.
Thank you

I have just started having the same issue on my desptop machine. One minute the shortcuts were working and the next they weren’t. Was there any resolution to this issue?

Hey, I found the answer to the ending, this time I spent a whole day solving the problem, and then I had planned to reinstall my computer like I did before, so I avoided reinstalling! I’ve had this problem a few times and the solution is that you need to check if you can use more than one mouse. Your computer will remember that you have permission to use these mice, even if you have disconnected the computer still thinks you are using a previous mouse, you need to check if the current mouse conflicts with a previously inserted mouse, because this problem is a mouse conflict problem

2 Likes

Amazing!! This worked - I had two bluetooth mice paired with my computer. Removing the old one (showing as “paired” but not “connected”) instantly solved this issue. Thanks so much!

1 Like

Sorry for the “revival”, but I also can’t Ctrl+Number any bookmarks, or even recall bookmarks set via the menu. I use a mouse and a §D-mouse, so I can’t just remove any of them. Is there a workaround of some sorts except cumbersome menu clicking?