Keyboard axis always 0?

Just upgraded to 13, started a new blank project created game-mode and controller, then add input axis, set up the event in the controller to print out. When I play the level there was no update to 1 / -1, it always shows as 0, started with up & down but it’s the same for any key.

However, the mouse inputs seem to work ok. Other than that, I moved the window aside and only once did the keyboard input work for a moment.

I installed 4.12.5 and everything is working ok.

Hello ,

After running a couple of tests, it appears that things are working as intended on our end. However, I would like to note that if you do not have the game selected and the game setup to receive input from the keyboard (Input mode game only or input mode Game and UI) the axis will only print out 0.0 as that is the default value. I would suggest running a test by setting the game mode to game only. I hope that this information helps.

Make it a great day

Where can I set that ?

I have provided some documentation that helps explain the different input mode nodes.

Link: Creating Widgets in Unreal Engine | Unreal Engine 5.1 Documentation

Still the same.

I have a couple of questions for you.

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a zipped down copy so that I could take a closer look?

Can you post a screenshot of you blueprint and your input setup?

link text

Hello ,

After taking a look at the project provided, it appears that you have two instances of the input that are being called. If you uncheck “consume input” this will allow you to call it from multiple blueprints. As it stands the Player controller (in the project provided) is consuming input and that is stopping the pawn from being able to call the event. I hope that this information helps.


I have provided an example of where to find the consume input check box below.

Make it a great day

Yes I have included 2 inputs but it was to see either way didn’t work. Sorry I should have said.