Key to Boolean

So I would like to change the state of an Boolean (see image attached)

In this particular case the bool should turn of a blendable texture in the scene.

Default state of the boolean is on when I enter the trigger volume.
Problem is it doesnt get turned off when I press K.

Any suggestions?

Hey -

You’ll want to make sure you have input enabled so that way the blueprint will respond to the key press. After the begin overlap node you should add an “Enable Input” node. Then to make sure the blueprint isn’t receiving input when it shouldn’t be you can use a Disable Input node after the End Overlap.


Hi ,

Thanks for your quick reply! I’ve done what you said but the bool isnt getting turned off.
Key presses are working as I can see by a simple print string test.

I’ve attached the complete blueprint hopefully you can see something in there.

Best Regards,

Hey -

Off of the “Player Controller” pin of the Enable Input node you’ll want to connect a “Get Player Controller” node. This should tell the blueprint which player to enable input for.