Keep Sound Playing After Leaving Falloff Area?

Hi,

I would like to have a sound continue playing even if the player leaves the attenuated area. That way, if they come back in, it will simply be playing from where they left the area, not begin again.

The problem now is, if I leave the attenuated area, the sound stops.

The sound keeps playing if I turn on Looping, but then it just starts from the beginning whenever they re-enter the area.

I simply want the sound to fire once, keep playing even if they are unable to hear it, then never play again.

Any ideas would be appreciated!

There is no simple, clean way to play “virtual” sounds. But see here for something related.

Theres a fix now apparently.
Open the sound, go to the Sound tab and activate Virtualize when Silent
Worked for me.

I came across a similar issue. Going into the Attenuation Override (or Attenuation Settings) of the sound and changing the default “Linear” to “Natural Sound” for the Distance Algorithm worked for me.

I’d like to post another solution to this: Turning the attenuation WAY up on all your sound cues will force them to sync (warning: volume multipliers are amplified here).

Jeriah’s suggestion worked for me (Engine Version 4.18.3). Thanks Jeriah.

can you explain this a bit more? what exactly am i turning all the way up?