Download

Just solved an error on the: "Attempting to move a fully simulated skeletal mesh"

I was googling for some quite a bit, and nothing much was helpful. So the issue, let’s say you are simulating a skeletal asset with some kinematic sub-objects. But keep getting that error (a tick warning actually) though everything is set supposedly fine. A vehicle in my case, where the root (a car body) is simulated, but the wheels are kinematic. The problem was in the Physics Transform Update Mode in the mesh component in the car’s blueprint. The problem goes away if the option is changed to the “Transform is Kinematic”. But then it adds another problem, since it’s normally having the springarm and camera components attached. The workaround is to attach the springarm to the root socket.

And a question. It is a bug, or i’m missing something?

no, its one of the “infinite complexities” of the engine’s phisx hack implementation.
the error is a warning, however you can’t mute it, and to publish in marketplace you can’t have it at all - for instance.
… Making the ability to set one bone to kinematic and another to simulated essentially completely useless.

it still works fine in some cases though- probably where people complained about it and the flag was removed. Like for ragdolls.

I had a similar issue with a vehicle i would possess. I narrowed it down to the first person camera.
Unchecking the box fixed it for me.