JumpMaxHoldTime broken

In my current character blueprint JumpMaxHoldTime is locked to 5 seconds, even though I have since changed the variable to 1 second, and later 0 seconds, you can still hold the jump key for 5 seconds before the input cuts out. This may or may not be preventing the Jetpack fuel system I’m trying to implement from working, but either way is extremely vexing, other character blueprints in this project are working fine.

Do you use a Stop Jumping node in combination with this?

I have stopjumping on release of the key, but no other forms of Stop Jumping.

Hmm well maybe this will help: In my project I have to set the JumpMaxHoldTime value really low for it to work. like 0.1

It does feel like there is an internal miss calculation where 0.1 really = 1 and .2 = 2 and so on and so forth.

Might be worth trying for your project.

This is very old but I just wanna throw this in in case somebody else has this problem, I found a “workaround” sort of.

Right click and add a set variable node for Jump Max Hold Time, but no need to connect it to anything. Select it, then in the details pane if you change the default value the change should take effect, at least it worked for me.

Obviously this isn’t ideal as it can’t be dynamically changed since the only option is to set the default value manually, but if your game only needs it at one value, it helps.

For some reason this setting and the JumpMaxCount is in the inherited parameters of the CharacterBP, but I honestly think it should be from CharacterMovement.