Jittery vertices in skeletal animation unless persona is open

I have an idle character animation with the vertices in the foot area jittering a little. It seems to specifically be the left foot.

The character’s feet aren’t jittering in 3DS max when I play back the same animation.

I then open the animation itself in the persona animation editor and the vertices are jittering a little worse there than in the game and on both feet.

The strange thing is if I open any model or animation in persona, suddenly the in game jitteryness disappears. The moment I close persona, the jitteryness comes back.

I also tried playing in 2 player mode and having another window pop up, and then the jitteryness disappears as well.

But if I play in 1 player mode with a separate window or as standalone game, the jiteryness is there just like it is if I’m playing in selected viewport of the editor.

I can try sending my assets in case it helps.

Hi illYay,

Can you send the asset for testing? I’ll look into this and see if I can replicate on my end.

If you don’t want to post the link here publicly you can send me the link via a private message on the forums.

Let me know! :slight_smile:


OK, I’ll be able to send those in tonight.

Hi illYay,

Since I’ve not heard from you in a while I’m going to mark this as resolved for our tracking purposes. If you are still having the issue and wish for me to take a look at the asset to reproduce on my end feel free to use one of the methods above.

Thank you!


OK, I finally got around to posting up the files:

Here are the assets for the creature that have the problem on my end: https://www.dropbox.com/sh/v1n22tx6876zlt0/AACG8uPU7gmChaDGqdnorgala

I tried sending you a private message but your quota on the forums is full so here is the link publically. I don’t really mind too much having it be public.

Oops. Sorry about that. I get email notices when it fills. I cleaned it out but must not have done so in time. :frowning:

I’ll take a look at this soon!

Is there any news on this one? I’ve still been seeing the jitteryness.

My only idea is some kind of float precision issues in the shader, but then again it works if persona is open so maybe not.


Would you mind uploading the asset again or sending in a private message to me. I cannot locate what I’ve done with it for testing. Thank you.


Hopefully this link works. Dropbox - Thing - Simplify your life

Thank you! I was able to download and check it out but I’m not seeing any jitteryness that was described.

Here is a video that’s about 20 secs long. You can see that I’ve got it running with persona open and even when it’s closed I’m getting the same results.

I’m not sure what your hardware specs are but it may be a limitation if you’ve got a few things open or running in the background.

Let me know what you think or if you want me to give it another test.

Thank you!


Have you tried the animation where the creature stands but turns in place a little? It may be harder to see on the walking animation.

I have a GTX 480 graphics card. 8 GB of RAM. intel i5 processor. Windows 8.1. Not sure what other specs may be relevant.

Thank you! I was able to see the jitteryness this time around.

I exported your animation “Thing_JitteryTest” as an FBX and imported that into Max.

I played the animation and “b_LeftFootOfset” seems to be the issue. If you play the animation you can see this bone move in that jittery motion.

You will need to fix this and this will resolve your issue. :slight_smile:


Have you tried looking at the raw .fbx animations preimport? Those are under Source/Animations. Those aren’t jittery for me when I import them into a modeling package. One thing I noticed is in 3ds max b_LeftAnkle does jerk forward a tiny bit for some reason but other than that is mostly fine. In persona, however, I can see b_LeftAngle actually jittering around the z axis a bit towards the end of the Thing_JitteryTest animation. I then exported that out back to fbx from the engine and imported that into 3ds max, and I saw that it too showed the strange jitteryness. And it was mostly around both ankle bones while other bones looked fine. I was looking at the transform gizmos of the bones with them selected while local coord space mode was on and saw the gizmos twisting a bit, while in the source anims they weren’t. The gizmos showed no jitteryness on the foot offset bones themselves, only on the ankle bones. In my mesh, the offset bones shouldn’t even affect any vertices since I only use the offset bones to help with IK. And this jerkiness only seems to start when a certain set of bones begins animating, like the lower portion of the creature’s body with the legs. Only arms moving wasn’t affecting the ankles.

I made sure to do the whole export process from scratch from the original .max file and made sure my skeletal animations are exported using FBX2014.

Could it be that there’s an issue with the importer because it seems like the jitteryness only occurs in the animation after going through the import process? It may be a problem on my end, but it’s hard to say what could be the cause at the moment since I’m following all the recommended mesh export tips.

Oh and thanks a lot for looking at this so far! Especially if it is all my fault :smiley:

Would you be able to upload the Max file and save it as 2013 version with all the animations. I’m really not an animation expert and I can’t get the fbx animations to show the skeleton when I import which is what I need to look at.

I’m not completely convinced this would be an import issue as I believe there would be many more issues like this popping up in our bugs sections.

This may be some work but would you be able to make a new skeleton and retarget the animations to that to see if that resolves the issue?

Thanks for all your help as well while I’m looking into this.


Yeah I’ll try that tonight. It could be happening for other people as well, but it’s very hard to notice this tiny little jitteryness problem so no one’s reporting it. It took me a while to notice it myself.

If you look at my source .fbx anims in 3ds max, all the exported stuff is initially hidden, which I guess is because it was hidden at the time I was exporting the data. In 3ds max I right click and unhide all to show the bones again, if that’s what you meant by not being able to show the skeleton.

Right-click unhide all did not show it for me.

So, for me I import an fbx file into 3ds max under file → import. Then I right click and select unhide all. If you hit the H key, it should bring up a scene outliner with a bunch of objects that are marked as not visible. This should only be a problem for the source .fbx files.