Jerky movement

I’m using 4.4.3
I have a pretty advanced game with a mouse point and click style movement via simple move to with nav mesh.
Everything was working fine until I noticed some jerky movement from my character whenever I moved. This went away when I kept the character blueprint opened while playing. Really weird. So I started compiling and saving every time before hitting play and it seemed to work. But when I tried playing from the Stand Alone option, the jerky movement was there. If I select play from Selected Viewport or from New Editor Window, it works fine.

I’m gonna have to rebuild the whole thing under a new project and with updated Engine version to optimize so I’m not too worried. I’ll probably find the glitch while doing that if it’s on my end. I was just wondering if this was an engine glitch that anyone else had seen before also?

My blueprint that handles my character movement is pretty simple, just hit result from mouse click which sends the location result to the goal of the simple move to location.

The question is: What is “Jerky movement”? :smiley:

Could you show us what you mean with “Jerky movement”?

I recreated the issue within my own project with some random assets I had laying around. There is a nav mesh bound volume, a sprite as my background, a blocking volume to walk on (replacing it with a regular plane and removing the blocking volume like in the template didn’t change anything), and MyCharacter which is a papercharacter with a capsule as the root component.

It occurred to me that I have other actors in my scene that navigate using the nav nesh + simple move to location without any issues. I’m pretty sure it’s not the mouse hit location as it does the same weather I hold or just click once.
So I went to look into my Player Controller BP and MyCharacter BP but try I as did, nothing I changed resolved the issue. I haven’t been able to recreate this issue in the Top Down Template provided by Epic either.

As far as the Controller BP goes, its pretty much a copy pace of the Top Down view template. I disconnected all events in MyCharacter BP which changed nothing, tried to mess in the Defaults tab also, and no change either. I tried changing the surface on which my character is, tried deleting and remaking the nav mesh volume. I don’t know, its weird. Why would it work fine in editor and window play?

Sorry about the censored stuff, my partner is paranoid.

Note. It used to work fine. I’m not sure when and how the problem got created.

Found the culprit. In MyCharacter BP’s Default tab, I had the ground friction set to 200. I can have it at 100 or lower and it works fine. Though I honestly don’t know what ground friction is achieving for me in this case haha I’ll just keep it at 0 from now on! 4 hours of debugging later lol I looked everywhere except at the ground friction. Makes sense I guess

Ok turns out ground friction is useful otherwise my character does slide when I click in the opposite direction. So 100 works fine, but 200 was too much, its weird that it didn’t show in the play in editor mode though.