Java:125: error: cannot find symbol

WHEN I TRY TO PACKAGE MY ANROID PROJECT IT SAYS java:125: error: cannot find symbol


show me your settings in android and android sdk

you probably have a lot of space) installed all in a row) :grin:
try and pack and show me log


if so, did you create the key?

It really Workeeedd!!! Thanks man ive had this problem for weeks…

1 Like

Bro you saved my life, I got the exact same error as the original post and this did work for me. Could you explain a bit more why disable API 33 will work?



in short? I don’t use Android Studio, but I know what problems can arise with it…
I have it connected sdk33… but there are no phones there :joy:

so you don’t lose anything) the time spent on finding and correcting the problem will not pay for itself even in a year :sweat_smile: Why? even on sdk 32 there are still few devices

1 Like

lol That makes sense, thanks

Man, you are a Genius!!! Yes, just uninstalling the Android SDK 33 and installing SDK 32 worked for me. But before this, I had to uninstall the Command Line Tools 33 and Install 29.03, also install jdk-8u301-windows-x64 and then manually set the SDK paths.

1 Like

thanks for the help java 122 123 125 does not appear anymore, but I have this as a result

respect man

1 Like

Oh my God, man, this was so frustrating… The same project was packaging just fine in UE5 but it was not in 4.27.2, I wasted so many hours trying to identify the issue.
This is going to increase my hate against Android Studio (by default it installed the Android 33 SDK).
Thank you for the help!

1 Like

I got problem when I delete sdk 33 when I open android studio it needs me setup sdk 33 again again@!

I did that but then I started getting failed with args MyProject\Intermediate\Android\gradle\rungradle.bat error. I have reinstalled Android Studio many times and still nothing is working. Please help.

Uninstall SDK 33 and remain SDK 31 works for me, thanks

a better way and no need to uninstall the SDK 33:
Project settings → Platforms → Android SDK → Set API level to android-31


When I package my project with these settings the game doesn’t open on an Android 13 device ?!!