I've tried everything, can't get levels to load on android

At the end of my level, the “Open Level” blueprint node is called.

This is what my DefaultEditor contains, map I want to load is “Level2complete”:


bReplaceBlueprintWithClass= true
bDontLoadBlueprintOutsideEditor= true
bBlueprintIsNotBlueprintType= true


I tried launching the game on the device and it launches but when it comes time to load the next level, it just crashes.

I also tried packaging the game, when I launch it, it says it can’t find the es2.apk file which is right above it in the same folder.

A bit frustrated at this point and would appreciate any help.

Hi there, upon reading your issue, i’ve 2 questions:

  1. Did you set in the Open Level node the map name of the level to be opened?
  2. Does it work in the UE4Editor?

If you use Launch to launch your game on your device, it will only launch the level you are in. To have all of your levels to work, you need to package your project from the file menu and then put it on your device.

About not finding the Apk file I don’t know.

1 Like

Okay I didn’t realize I had to drag it on to the phone, so I took the android folder and moved it onto the phone (it wouldn’t stay on the SD card for some reason). Everything seemed to install fine but when I go to open it it says No Google Play Store Key

I know that there’s a NoOBBInstall bat file, what do I do with this? When I try running from the PC it says “can’t find GmaeProject7a-armv7-es2.apk” to install. On the phone it won’t let me run it.

yeah works as expected in the editor and in mobile preview, just not on the phone

Hi ,

Did you run the bat file from the directory you packaged to? It will run some adb commands to find the sdcard install location for the OBB file if necessary, uninstall any existing APK with the same package name from the device, and install the APK you created, followed by the OBB if needed. You will not have an OBB if you turned on the “Package data in APK” checkbox in Android Project Settings. If you don’t turn this on, you must have the OBB on the device; do not run the NoOBBInstall.bat; it was intended to be used to test downloading and it has been confusing people. I’ve decided to disable generating it in 4.11 going forward.

Here’s exactly what I did.

  1. Enabled “Package game data inside .apk”
  2. File->Package Project -> Android -> Android (all), it packaged it onto the desktop.
  3. Connected phone and dragged the “Android” folder onto the phone
  4. On the phone, I just opened the .apk file and it proceeded with the installation.

After installation, when I try to run it I get a black screen for a moment and then it just exits. Launching levels individually from the editor works. Can’t seem to figure out how to properly package everything.

Try running the batch file to install the apk with adb and see if that works.

I tried running the batch file but then it says “can’t find GameeProject7a-armv7-es2.apk”

What I’m trying now is making a new project using the default firstpersonBP example and seeing if I can get that to work.

That didn’t work either. I install the game by running the apk file and after it’s finished installing, it just crashes. Upgraded to 4.10.2 and same problem.

I fired up android studio and used the logcat to see what was going on, it seems that the phone runs out of memory.

“01-25 06:54:29.044 29362-29379/? D/UE4﹕ Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 91]
01-25 06:54:29.044 29362-29379/? D/UE4﹕ Ran out of memory allocating 16777216 bytes with alignment 0
01-25 06:54:29.059 29362-29414/? I/AndroidRuntime﹕ VM exiting with result code 0, cleanup skipped.
01-25 06:54:29.499 2385-3276/? D/SSRMv2:Monitor﹕ SIOP:: AP = 330, Prev AP = 330, Duration = 10003
01-25 06:54:29.584 2385-3053/? I/ActivityManager﹕ Process com.YourCompany.LevelLoad4 (pid 29362) (adj 0) has died.”

Not sure why this would be since I’m just running some simple starter content.


Realized I can just launch the whole project from the editor by using the project launcher. However, I’m still getting the same issue, it just crashes now without starting.


Got it working, somehow.

Might I ask how you got it to work?