Download

Ive had enough im tired...

I really am tired of wasting my life away, Epic just tell us blender is no good for UE4 and shoudnt be used.
Really, in unity while not perfect my animations and exports works properly but in UE4 its a disaster ive wasted so much time trying to get any skeletal mesh and weapons(sockets) to work properly, its impossible.
And no this is not comparison with bloody unity its just UE4 thats impossible to work with, just tell us you HAVE to use maya and then i understand what i have to do next.

I have all the possible problems, rotation problems, scale problems, UE4 imports bone shape meshes and IK bones along with the skeleton, the base armature is scaled 100x which makes my weapons added to sockets 100x biggers, if i try to resize down my skeletal mesh base to 1 it jumps to some random high numbers after i enter scale to 1.0 and hit enter like 9800 making my skeleton huge.

I keep trying applying scale,rot,loc all sorts of blender export settings nothing works, ive watched all youtube videos regarding blender to ue4 including the epic official one, reset blender settings nothing works.

Other major issues i cannot easily reimport animations, and skeletal rig after i modified them, only headaches and waste of time = ue4 asset import pipeline.

In unity its so easy copy the .blend file to project and everything just works, save changes in blender to .blend file and gets automatically reimported with new animations or changes done in unity, or export to FBX in asset folder, works just as good no problems.

Just for comparison i made maya student license and made a skeleton for my mesh with a simple animation, imported in my project and it has none of the blender problems, conclusion is that ue4 doesnt work with blender or its broken.

I want to know if they will fix the blender pipeline or not ive been trying to get into this engine for over a year learning and learning but skeletal meshes and animations have always been broken they never work properly.

This is too much work to throw away all the time just because ue4 importer gave me the middle finger every time.

I don’t use Blender but I know that people have been successfully using it with UE4 for a while.
Currently Epic hasn’t announced any plans to work on improved Blender support, doing something like supporting the Blender format is unlikely given that’s a lot of work for a single format. Part of the issue is that Blender itself has poor support for the FBX format which isn’t something that Epic can control.

I use blender exclusively. I don’t do too much animation but I have had successes with whole skeleton, animations, IK, etc… The pipeline is a bit hectic but once you figure out what works for you, you get the hang of it. Keep at it for a little while longer and you’ll be all set.

The problem isn’t really at the Blender side though, scaling of armatures doesn’t really work with animations. It just happens that default settings with Maya works so no one notices this problem. (read Animations from Blender using default settings don't work in UE4 - help fix the Blender FBX exporter - Feedback for Unreal Engine team - Unreal Engine Forums for more info)

The exporter part of the Blender FBX addon is actually really solid which you can tell by changing the Blender settings to match Maya (cm instead of m), then things work perfectly. This causes a bunch of other issues in Blender though (because Blender stuff works best in meters instead of centimeters) so it would be nice if this could get fixed. Especially since Blender is on the rise and will continue to be so for sure after the 2.8 release.

Blender to UE4 is kind of broken with default settings for sure. However with changed settings it should work properly.

Armature getting 100 scale means either that you’re not using metric 0.01 scale or your transforms for the rig and mesh are not applied. Both the rig and mesh should have 1 for scale and the dimensions should say 2m or so in Z.

UE4 importing bone shape meshes means that you’re exporting everything in the scene instead of toggling Selected Objects in the exporter. Exporting IK bones means that you’re not using Only Deform Bones in the Armature settings.

Reimporting animations and skeletal meshes should work, I do so myself pretty often. Anyway you can just post a bunch of screenshots (or a .blend) and we can solve all the problems one at a time.

I haven’t tried using Blender and UE4, but what you’re saying sounds like a total disaster. I would rather use Maya as it is more professional than Blender. Autodesk Maya 2015 is better than Blender 2.78. Also, I am using UE4.16.

Sorry not really, Blender is also a vcry powerful tool and can do some things better out of the box, and this is a coming from a Max/Maya user.

I hope Epic does pay closer attention to Blender users and help integrate things better there. If they can’t do it I hope they could provide some resources for a small outside group to dedicate themselves in doing so.

Bottom line is many if not majority of Indies would love to use Blender either now or in the future simply because it is free and getting ever more features, Autodesk just sucks the financial and mental health out of its users, and for indies on a budget, (which they are 99 percent of the time), paying thousands of dollars per seat for either software (especially for game development) is becoming more and more of a very big no go to situation.

If Epic starts officially supporting Blender then that would be an encouraging move.

Well i managed to fix the size since it was my fault aparently, i set the scale to metric and 0.01 in blender but my mesh had 3.5cm height scale instead of 3.5m height, i was working on very small scale and export to large scale to make it look regular size in UE4.
The rotation problem was because i was applying all settings to armature but dunno why it flipped my mesh after import.
Still its a lot of headaches to find the right settings.

This worked on a new simple test riged mesh, the two other skeleton rigs/meshes i had trouble past days still dont work i assume they are broken in blender and i have to remake them, yet in unity they work so theres that.

These nuances are a pain to learn, but very necessary. You will have nuances in every software. I’ve had the metric issue before…
What William said is correct. Blender can do just about everything, and more. Know that there are tons of scripts available for blender, and plugins.
There is a UE tools plugin. [ADDON BLENDER] UE Tools - Community Content, Tools and Tutorials - Unreal Engine Forums
One thing I always do is select mannequin in UE4 go to create static mesh, and export as FBX. Then import into 3d modelling software.
Now you will have a UE4 scale perspective.
This is worth reading in entirety.
How to Export a fbx-file in Blender with reduced keyframes | 3DHaupt and the link to get autodesk fbx convertor.
Autodesk | 3D Design, Engineering & Construction Software
There is also the BOS fbx import/exporter. Bos FBX Importer/Exporter for Blender 2.77 by amyaimei on DeviantArt
I used to have a .txt checklist for things to do that I always forgot before exporting.
Then I got a gaming mouse with mapped keys and it’s a lifesaver. as you can just click down a row of keys before exporting like a checklist.

I love doing characters for UE in Blender.

I wrote up my process on the wiki:

I chose to follow the UE4 rig for the characters to allow retargeting. If I didn’t do that, even working in Maya would create headaches.

I believe that Epic did contribute something like $10,000 to improve the FBX exporter in Blender about a year ago and that made it quite usable for my needs. At present I am using Blender to export rigged characters to UE4 and they are working perfectly for me.

I found a hint somewhere in the comments of a youtube video about Blender->UE4.
What works for me is this:

  1. In Blender scale everything in Edit mode by the factor 100. select all, and press “s 100 return”. Do this for the armature and the mesh.
  2. Select the armature and the mesh in Object mode and ‘Apply Scale’.
  3. When exporting de-select ‘Add leaf bones’ in the exporter menu. Leave the other options at their default.
  4. When importing in UE4 set the global scale to 0.01.

I have no idea why it works or if it works universally but I was able to import skeletal meshes this way.

UPDATE: I’m a Blender user :stuck_out_tongue: