I've been following the UMG UI Designer quick start guide, play button is not working

I keep following the steps on this guide here: UMG UI Designer Quick Start Guide | Unreal Engine Documentation and everything seems to be the same except I set the OptionsMenu ZOrder to 1 also because the options menu didn’t seem to work until I did that (I do not know if the guide failed to mention it or if my work around was incorrect, guide only asks for MainMenu to be set to ZOrder 1 from what I see). So other than that everything is looking to be exactly as the guide says to set it up but my play button does not close the menu and open the game. If I click off the buttons I can here the shooting in the backround as well if that helps identify what I may be doing wrong.

I’m thinking there is something wrong with the Level BP event start that is causing this, but I have just started UE4 so I am a bit clueless here.

Also I keep getting an error in the log about the MaxAmmo text display each time I hit play, I’m assuming this error does not have to do with the in-game Play button not working.

Could you show what you have hooked up to your Button Onclicked event?

I apologize, I forgot about this part. One thing to note that seemed unusual to me is I had this open when playing to see if it would show the communication as I clicked the in-game play button and nothing showed. Although, it didn’t show the communication of the other buttons that do work when I clicked them either so maybe that is normal.

For the debug, make sure you have the correct object selected in the debug filter once it’s running, that might be why you don’t see anything happening.

As for the actual problem, I don’t have a concrete answer, but I have a theory. Although it doesn’t explicitly state it in the documentation, I suspect that the MainMenu is actually its own level, not the FirstPersonExampleMap, mainly because if you setup those functions in the event begin play of the example map, they would just execute again when you load the level (It would again create a mainmenu widget and add it to the viewport). Maybe try creating a new map and setting up those nodes on the begin play of that level instead.

Also, make sure that your world settings for that level are setup correctly, like this:


Actually I just confirmed this is the case. If you go the next section (where you create an In-Game Pause Menu), they actually load up a level called MainMenu.

You nailed it on the head here. I recalled that the guide asked to make a new level at the very beginning, and I never understood what the use was. After going through the whole thing again and searching for the word “Main” which they asked it be named I found this:

Looks like that was the important part I missed, I created this event in the ExampleMap and not this separate “Main” level that was created in the beginning. Thank you very much, now I can finally sleep well and continue this tomorrow!

Awesome, glad I could help. Sleep tight. =)

Edit: Oops, it seems there’s a bug in answer hub where my replying to this unmarked the answer as resolved. My bad.

I was wondering what happened also, I thought it was because I didn’t hit accept somewhere and have been looking around for an accept button lol. I just hit it as resolved again and refreshed, looks like it stayed now.