Download

I've almost done what people are saying is impossible [Blender to UE4 Anomation] (need help)

so I tried making a idle animation in blender, it works except the legs seam to be morphing together
http://gyazo.com/429b1f684c1b35728571a2cc43fc7ecb

if it helps I’ll be providing the files (feal free to even take them for your self, this is a Alpha character I quickly made in Mixamo’s Fuse, it will probably be replaced)

Try this:

Use Blender 2.7.4 and export everything with ASCII exporter (Animature + Mesh selected). Also set the scale to match Unreal. Also use latest Unreal public version.

doesn’t Unreal use FBX?

yes UE4 does use fbx(it can also use obj), blender has 2 fbx exporters you can choose from (“fbx 6.1 ASCII” or “fbx 7.4 binary”), using the old 6.1 version often fixes issues like the one you have.

also I have no issues getting animations from blender to UE4, the people that say it’s impossible just haven’t got the workflow right yet.

I only have one export to FBX on mine, I checked User prefs and there seams to only be one there to.

yeah i knew it was poible, the first time i did it it was rotated 90 on the X axis, it had a simple fix.

what version of blender are you using?

both the exporters are contained in the same add-on so it only shows one, you can switch version in the export settings.

–edit–

here’s a pic of what I mean

When you go to the export page in Blender, there under FBX exporter you can switch between FBX ASCII and FBX BINARY (default) version.

your picture isn’t working, I’m using 2.7.4
http://gyazo.com/6d6a5104154fbeb3cee235fd21674c95

sorry for the late response, I think my laptop is about to commit suicide.

anyway is the pic working now?

as unit23 said its on the export page(after you click “export>fbx”)

oh i see it now, also the pic works now

unfortunately I can’t test it now, cause the hard drive its stored on is some where else

ok I got my hard-drive back.

when I use the other type of FBX (ASCII) I get this message when I try import

"
Failed to import ‘F:/Sean [Owner]/blender/Blends/My stuff/Fuse/Charictors/Test/Test 1/Test_Idel.fbx’. Failed to create asset ‘/Game/Test_Idel’
"

Edit:
something I missed it didn’t ask for a skeleton it thought it was a static mesh

:confused: I tryed importing it as the other version agine (binary) it it just decided to work
http://gyazo.com/5552ac22e1e3f1bb4211b3dfbc3197e9

maybe it was part of the UE4 update?

Can’t say for sure, but I was having a really strange problem with a model exported from Blender that just magically went away a few days ago as well. I don’t think it was 4.7.4 that did id, as it went away before I installed that. I was assuming it was some change between Blender 2.74 RC2 and 2.74 final, but haven’t tested that theory. Am just happy it’s working now.