iTunes Connect invalid binary

Thank you for looking into this more Pete, and it’s awesome to hear progress is being made :). One last question. Is there a guide about how to remotely sign the IPA on a Mac from my PC? Does it require programming or is it something I could do with a blueprint only project?

You could do it with a blueprint project if I changed the code in the engine in 4.11. However, I was able to successfully upload an IPA signed on PC last night. I need to do a few more tests today and check over everything one more time and then we should be good to go.


I submitted a fix yesterday, so it should be in the next Preview. Also, it will be in the next 4.10 hot fix.


Hi Pete, I have exactly this same issue, is this going to make it to a 4.11 update? Any ETA for it? I’m stuck as well on this, need to upload an app and waiting on this. Thank you for the efforts! Looking forward to hearing news soon

i realize this will be fixed in the next hotfix per thread discussion, but for those that need to upload immediately for various time constraints, there is a great tool called ‘iReSign’ which is free and on github. that allowed me to package everything on the pc with UE4, and then just run that ‘iReSign’ script on the mac before uploading the binary. upload and submission through itunes connect was successful after that minor extra step. this is also in accordance with initial answer of ‘sign on mac works fine’ but i’m somewhat useless when it comes to mac os, so this script was really helpful.

I’m so excited. Thank you so much for looking into this! :smiley:

Ya, it was in it. Could you post your log? Also, the root authority certificate from Apple expired a few days ago. You will need to update that certificate on your PC.
Go here: Apple PKI - Apple and download the WWDR certificate (Expiring 02/07/23). Double click it and install it on your machine. That may be the issue you are experiencing. If not, post the log and I’ll take a look. You may just have a different certificate/provision setup than I have and so the fix didn’t cover it.

Was this supposed to be in 4.10.3? I’m still receiving packaging Errors. It won’t build on a PC.

And just to be clear, I tested my fix last night against the updated WWDR certificate and it worked (uploaded a new Tappy Chicken to iTunes Connect, entire thing built and signed on PC).


I installed the WWDR but still cannot package the project for iOS.

I’ve attached the error log.

Just to make sure I wasn’t crazy I redid everything to the letter on Please note this is my 2nd game shipping in iOS and was able to ship a 4.9 project. I am still using the same PC but different provisions, and certificates then the 4.9 project on this latest project. Also note that I am using a iOS Distribution Certificate. Could this be the issue?

I also went thru various steps in this other answerhub. But was directed to this one as the same issue. [4.10]Unable to Build to iOS in 4.10. But same Provision and Signing keys work in 4.9 - Mobile - Unreal Engine Forumslink text

Ok, this is a different issue:

E:\UnrealProject\GravityWall\Config\DefaultEngine.ini, line 110: SigningCertificate="iPhone Distribution: Olivine Games

Go to that file (DefaultEngine.ini) and at line 110 add a quote (") to the end of the line. Somehow the quote is missing and so it can’t properly parse the file. After updating the file, package your game from the editor. I’ll take a look at the code and see if there is some way we drop it when writing out the file after getting an update to the project settings.


So sorry for opening this ticket over again. It looks like I’m able to build. But submitting it thru Application Loader, I now receive this error. After receiving it the first time, I remade the Certificates, and the provisioning files. And had to do the fix you mentioned again. And I continue to receive the error. Any help would be greatly appreciated.

I also just tested making a clean project in 4.9 adding the same Certificates and provisioning in a project and I was able to submit the project using Application Loader. I also did not have to do the fix you mentioned that was fixing the build issue in 4.10

Can you post the log from the editor that created the IPA? It’s possible it picked the wrong certificate and signed it with the development one. Or you can PM me the IPA and I can extract the provision inside and take a look at it. The log would be faster :slight_smile:


I’m not exactly sure how to PM you. But here is the new error log :slight_smile: Thanks again Pete! link text

That does look like it is signing with the correct certificate. It is using the NeoDash provision. Do you know if that provision works with multiple certificates?


No I don’t know if it works with multiple certificates :(. How would I check?

When you created the mobile provision you would select more than one certificate that it works with. More than likely you didn’t do that. It’s possible that something got changed after the code sign, but before you uploaded it. That has happened in the past, but I thought we had gotten all of those bugs resolved.

I also just did a sanity check for 4.10.3 with one of our content-only projects and it did upload properly. What I noticed tho is my code sign on PC took almost 30 seconds while yours took about 2 seconds which seems a little odd. I’m going to update to 4.10.4 since that is what the log is from and see if I get similar results.


Just checked the mobile provisions and it will only allow me to select one certificate. Which is the correct one I’m calling upon (Even tho there is another with the same name). Please be advised that these provisions and certificates do work in 4.9 builds of a clean project I made.

Ok, my 4.10.4 build also worked. I’m going to need your IPA to be able to figure this out. I’ll talk with our support and see how you can send it us.


Our support guys will contact you in a bit on how to get it to us. In the meantime, you mentioned two certificates with the same name, is that correct?