Item won't place..Out of idea

So I made a small mod a week ago, everything was working, uploaded and received good feedback, I decided to work on it a bit today but the item won’t place anymore:

The mod allows admins to place floating islands as mesh item, pretty simple (for most of you, for me it was a good learning experience).

  • I can summon the item and see it in my inventory (there is no engram, summon only)
  • I can use in inventory or place it in the quick bar and use it from there but nothing happens, before it would show the mesh, then clicking would place it.
  • I do have it in the “Additional Structures to Place”.
  • It was working a week ago after I uploaded it (still working on the workshop, I haven’t uploaded the new non-working version, “Haven Islands”)

Here is what I changed (in detail in case something matters):

I re-imported the static mesh (new UV map and scale of uv map changes in blender).
I changed the material to a new one (vector up material to show grass on top, rock on side/bottom), deleted old material after switching it to the new material.
Placed all textures (copies and renamed) inside the folder with the material.
New material is inside a folder next to the item folder in the root of the mod.
Removed a few things that wasn’t used (static mesh of grass I had used to test on but is not used anywhere in the mod).

Note: Before modification, I made a zip file of the mod folder, I tried shutting down the dev kit, moving the new one and putting back the old “right after upload” version and I am having the same problem. I am hoping it’s something veterans are used to and know a trick to fix it. Let me know if you need more info.

Thank you in advance.

So after a few days of looking around, it seems I had left out ONE setting to change, so for those that might be having the same problem, I had modified the “GameMode Overrride” in world settings, but forgot to set “Primal Game Data Overrride”.

FYI: You only need to override the game mode in the primal game data (NOT in the orange level file) and ONLY if you actually edit the game mode BP. If you do not edit the testgamemode BP then you do not need to override it. Leave it set to the default.

Thank you for your reply, it seems 90% of tutorials out there (that I have found) tell you to change the Game Mode in the level and primal game data file, from what I understand of the logic, you are correct, but either way it is not working for me.

Apparently, it was a fluke that I got it working, something is just not right. While trying to make a new mod, and even now once again my first mod which was fully working, is not letting me place items in game.

I am lost, to try to find what is causing it, I tried making a new mod, with a fresh dev kit install, to see if anyone could figure what is wrong. Here is a step by step of how I am making a new structure mod, please let me know if you notice anything.

  1. Make a folder in Mods called MyMod then copied the 3 generic mod files to the MyMod Folder.

  2. Rename the files as follow: “MyMod” for the Level file, “PrimalGameData_BP_MyMod” and “TestGameMode_MyMod”

  3. Changes to “PrimalGameData_BP_MyMod”:
    Mod Name: Mod Test
    Default Game Mode:TestGameMode_MyMod
    Compiled, saved and close “PrimalGameData_BP_MyMod”

  4. Opened Mymod (Level), in World Settings, changed Primal Game Data Override to “PrimalGameData_BP_MyMod”, cleared the “Force Load Map Name”, then saved.

  5. Reopened TestMap and changed Primal Game Data Override to “PrimalGameData_BP_MyMod”, then saved.

  6. Created “Materials” and “Objects” subfolder to the “Game/Mods/MyMods” folder, then imported the files crate_D, Crate_N, Crate_S into “Materials” and Crate.fbx into “Objects” (links at the bottom of the post).

  7. Right clicked on crate_D and “Create material”, opened the new material, drag and dropped crate_N and crate_S and linked them to Normal and Specular, saved and close the crate_d_Mat Material.

  8. Imported the crate.fbx into the Objects folder, unchecking Auto gen of collision, import mat and textures and cliked Import.

  9. Opened the new crate static mesh, Menu collision, add box simplified collision, dragged the crate_d_mat into the mat slot in the details, saved and closed the static mesh.

  10. Clicked on the main folder “Game”, then in filters, typed in WoodTable on the right side, and copied the blueprint WoodTable (woodtable icon and dark blue line at bottom), “EngramEntry_Furniture_WoodTable” and PrimalItemStructure_Furniture_WoodTable files to my Objects folder.

  11. Renamed the 3 files to MyCrate, EngramEntry_Furniture_MyCrate and PrimalItemStructure_Furniture_MyCrate

  12. Opened the file MyCrate blueprint and changed:
    Static Mesh to “crate” from my Objects folder.
    Comsumes Primal Item to “PrimalItemStructure_Furniture_MyCrate”
    Unchecked “Requires Placement on Structure Floor” (so we can place it on ground to test).
    Pickup Gives Item to “PrimalItemStructure_Furniture_MyCrate”
    Descriptive Name to “My Crate”
    Compiled, saved and closed the MyCrate blueprint/

  13. Opened the file EngramEntry_Furniture_MyCrate and changed Blue Print Entry to PrimalItemStructure_Furniture_MyCrate, then compiled, saved and closed it.

  14. Opened PrimalItemStructure_Furniture_MyCrate and changed:
    Descriptive Name Base to “My Crate”
    Item Description to “A test wood crate”
    Item Icon changed to crate_D from the Materials folder.
    Structure to build to MyCrate from the Objects folder.
    Compiled, saved and closed “PrimalItemStructure_Furniture_MyCrate”.

  15. Opened PrimalGameData_BP_MyMod from the MyMods folder and changed
    Additional Engram Blueprint Classes, I added the “EngramEntry_Furniture_MyCrate”
    Additional Structures to Place, I added “MyCrate” from the Objects folder.
    Compiled, saved and closed it.

Now, all this is typical of creating a new mod, seen ppl also change the Default Game mode in the TestMap and in the MyMod level file, but I believe it is not required unless you make changes to the TestGameMode_MyMod file.

I used the following command to spawn the item:
cheat giveitem “Blueprint’/Game/Mods/MyMod/Objects/PrimalItemStructure_Furniture_MyCrate.PrimalItemStructure_Furniture_MyCrate’” 1 0 0

Int he dev kit, everything is working, I can see the engram, make or summon the crate, place it, all is working perfectly.

Now for the baking:

  1. Click Steam Upload and fill in the fileds:
    Maps: MyMod
    Test mod output, I put in the URL of my game mods folder so I can test before upload.
    Preview image, I used the crate_icon.png
    Title is “My Crate”
    Description is “A test Crate”
    Click Cook Game Mod.

In local game, the mod appears since I put in the mods folder before baking. I add My Crate and only it to the list of mod, but once in game, the engram is not there, I can summon the crate, see it in the inventory, move it to my actionbar, but when I use it (from bar or inventory), nothing happens… no green outline, nothing.

PS: if it will help, I can zip my whole “MyMod” folder for someone to try.


Well I once again figured it out… it seems that, while putting in the mod folder path before baking makes the dev kit install the mod in the game, it will not work from there.

However, if you upload the mod to the workshop, then everything works as in the dev kit… I wonder why that is, why have the option if you can’t test it in game without uploading it, I might still be missing a piece of the puzzle, but at least, things are working right now.

The testmod output is for just that. Testing the mod locally w/o having to upload it to steam. And it should work. Did last time I used it anyway. It makes 2 folders, one with your mod name and one that is numbered. Some things in a mod do not work unless you move the contents from the named folder to the numbered folder. Or vice versa. I can never remember which way it should go.

I do think it worked once or twice, which is why it was one of the last thing I tested, it didn’t make sense that it would not work… I did notice it makes a folder with the name of your mod then a 123456789 folder linking to your named folder. Guessing the linking had trouble… either way, I am going to see about using a hidden upload seamid for all my mods when I want to test.

You will drive your self crazy if you use steam to test your mods. P0k3r is correct in that the output for the mod will put all of your mods contents into a folder with your mods name. You need to move the contents of that folder into the 123456789 folder for the mod to work. I wrote a small program that does this for me automatically when it sees the .mod file appear and then copies it to the correct locations in the server and client so I can quickly test.

It works just fine doing it manually though.