It is impossible to generate compressed cooked assets in 4.8 and 4.9

Build version: Bug exists in binary releases of 4.8 (4.8.3-2634408+++depot+UE4-Releases+4.8) and 4.9pre4 (4.9.0-2657513+++depot+UE4-Releases+4.9) at a minimum

Repro steps:

Using the Project Settings dialog in the Editor, I’ve checked the “Create compressed cooked packages” box in the Packaging section, then I hit the “Cook Content for Windows” item under the File menu.

Actual result: The resulting cooked assets are plainly not compressed: For instance, one texture which was 281k in the Content folder ends up being 5.4M in Saved/Cooked/WindowsNoEditor after cooking.

Expected result: cooked assets are similar in size or smaller to corresponding files in Content folder.

I believe the change that broke the functionality was this one: since TargetPlatform->SupportsFeature(ETargetPlatformFeatures::ShouldUseCompressedCookedPackages) always returns false as far as I can tell. Commenting out that line fixes the problem. (I’d send a pull request, but I’m not sure what the intent of the change was in the first place)

Hey Sfreeland.bhvr,

Which project did you produce this on to receive these results? I followed your steps and my two projects were nearly the same size. 4.8.3 - 527 MB | 4.9.0 Preview 4 - 528 MB, for a blank project with starter content.

Looking forward to hearing back from you, thanks!

Hi ,

I tested this by creating a new project from the FlyingBP template, and then imported a very large, very sparse texture (basically 4k in size, all transparent with just a stripe through it). That compresses very well, so the difference between cooked vs uncooked is easily noticeable.

By the way, you only mentioned one number for the asset size in each for the two versions you tested – are you comparing cooked vs. uncooked asset size?

The cooking compression has performance implications for loading, we have disabled this for almost all platforms until those issues are resolved.
Compression of the pak file is a much more optimized code path this is what you should use. To do that enable compression and also enable store files in single pak file.
Or if you are creating a package from the editor then just use file → package.

You can see the compression amount using the unrealpak tool to uncompress the built pak file.


Indeed; we have already switched to compressed pak files for exactly the above reason. Nevertheless the Project Settings UI misleading, and I’ve seen a few parts of the documentation which reference this disabled feature as well.