Download

Issues with Twinmotion Lightmap UVs

I’m having trouble with Lightmap UVs in my project. I imported the file from Twinmotion with ‘Generate Lightmap UVs’ enabled, and everything looks fine in the preview window:


However, after building lighting, all of the lightmaps are messed up:

Under ‘Lighting Results’ it says I have overlapping UVs, what settings do I change so that it uses the right ones?

Hi!

I’ve never used Twinmotion!!
But when you generate lightmap uvs in Unreal the Source and Destination uvs should be different imo…
Could you show one of the problematic mesh’s lightmap uv please? Do they have multiple UVs? …maybe when building light you’re just using the wrong uv as lightmap… ?

1 Like

Thanks for the reply! That sounds likely, there are 2 UVs that came with each of the models:

UV Channel 0:

UV Channel 1:

Channel 0 is obviously not right, but I’m not sure if Channel 1 is right, either. I can unwrap and generate new lightmap UVs, but none of them work properly.

Generate Lightmap UV’s is not a complete solution, all that option does is it copies the existing UV’s to a new channel and then runs a flattening algorithm and packs them. If your mesh doesn’t have an existing set of UV’s that has the seams split and can be flattened without things overlapping then it won’t work.

1 Like

That explains a lot, I guess Twinmotion files don’t natively contain/export that information. I’m having limited success generating new workable lightmap UVs in the editor, a lot of the models in my scene are fairly complex so the lightmaps have visible seams, even with 2048*2048+ resolution.


Is the only alternative exporting to Blender and rebuilding lightmaps from there? If so that’s a shame, because it kinda defeats the purpose of a Twinmotion to Unreal plugin.

It looks like the UV’s have been split up far too much for that one. I don’t know what options there are for twinmotion>Unreal but you can see there there’s way too many seams. Some automatic UV tools make the seams based off angles between polygons and it can split things up too much if the angle threshold is too low.
If you don’t have any options with Twinmotion>Unreal then you’d need to export it to a 3D tool like Blender and make them yourself.

1 Like