Issues with Stepping and the CharacterMovemementComponent


The current Character blueprint I have setup is similar to the FirstPersonCharacter project, but I’m running into issues that don’t occur when using that blueprint, despite their similarities.

My current character only has collision with the default capsule component, which I believe may be the source of my issues but I’m probably wrong. I’m relatively new to Unreal. My character will step onto small objects or meshes despite the objects having the CanCharacterStepOn property set to No. After that, I tried setting the maximum step height on the CharacterMovementComponent of my Character to 0. Despite this, my character still finds their way up onto small objects and ledges. This causes other issues as well. Small Physics Objects will send the character camera spiraling and rotating, so I disabled my character’s ability to interact with Physics Actors in the CharacterMovementComponent. This did resolve the jittering and spiraling, but I discovered that when my character would step off these small objects the camera rotation would be altered a small amount suddenly, or the character would slide a few feet on their own, almost as if they tripped.

My character movement is identical to the FirstPersonCharacters, except I don’t have a jump.

It’s a longshot, but I was hoping there was some property or solution others have discovered prior to my post. Thanks!

Turning off physics is a bad idea - then you can’t interact with anything in the environment that is marked as a physics body/object (by default anything that simulates physics).

The best solution would be to add custom collision to the elements you do not want to step on, so that the character cannot possibly step up on them.

Additionally - while changing the setting on the character end is a bad idea, you can always overwrite the default collision of the item so that it will ignore the Pawn (the default collision channel of a movemnet/capsule comp.) Shift it to Overlap, and the character’s collision box will pass through it.

A few screenshots of the assets in questions may also help elucidate the actual problem here.

Another setting you can play with is the Perch Radius, in the movement component.