Issues with RigLogicModule After Converting Project to UE5

Deleted previous topic, I couldn’t figure out the categorizing it seems.
I converted a 4.26 project to UE5 containing a MetaHuman import. The errors I receive at startup are as following:

/Script/RigLogicModule : [AssetLog] ...\Content\MetaHumans\Common\Face\Neck_CtrlRig.uasset: Failed to load '/Script/RigLogicModule': Can't find file. /Script/RigLogicModule
/Script/RigLogicModule : [AssetLog] ...\Content\MetaHumans\Common\Face\Face_PostProcess_AnimBP.uasset: Failed to load '/Script/RigLogicModule': Can't find file. /Script/RigLogicModule
Failed to load /Script/RigLogicModule.RigUnit_RigLogic Referenced by RigLogic
/Script/RigLogicModule : [AssetLog] ...\MetaHumans\Yuri_01\Face\Yuri_01_FaceMesh.uasset: Failed to load '/Script/RigLogicModule': Can't find file. /Script/RigLogicModule
/Script/RigLogicModule : [AssetLog] ...\Content\MetaHumans\Yuri_01\FemaleHair\GroomBinding\Peachfuzz_M_Thin_f_head_Archetype_Binding.uasset: Failed to load '/Script/RigLogicModule': Can't find file. /Script/RigLogicModule

I tried looking up the Script/RigLogicModule path up in the UE repo, but couldn’t find it. RigLogic 6.2.0 is enabled, verified UE5, still no luck. I also tried reimporting everything related to MetaHumans through Bridge.

I tried doing an animation through a LevelScene. It’s unclear to me why, other than a possible connection to the above, but it crashes at some point. It so far has crashed when enabling the FKIK option in the helper widget and when moving stuff around randomly.


the log: Struct ‘/Script/RigLogicModule.RigUnit_RigLogic_Data’ cannot be found.
I did what? use metahuman NPC in LevelSequence,And put it’s reference into a datatable.
So this Log reported.
When my datatable clear this data,the log disapear.

1 Like

If you get ‘failed to load’ script/RigLogic or script/LiveLink errors, go to the .uplugin files of those plugins in the engine and change their LoadingPhase to PreDefault.

My metahumans kept breaking in UE 4.27 because it was failing to load these plugins fast enough and it took me 3 days to figure out.

1 Like