Download

Issues with packaging for Mac

Hi guys

I’m trying to get my head around packaging a game for the Mac and have a few issues.

  1. Starting the game(just starting the .app doesn’t work)

Following a forum thread / answer I have found on the topic, I’m starting the game like this:


open -a UE4Game-Mac-Shipping.app --args ../../../Sensorial/Sensorial.uproject -ResX=960 -ResY=540 -pak

but still get the following error


"Failed to open descriptor file "../../../sensorial.uproject"

I have checked the path several times and an absolute path does not help either. I have also checked file rights / attributes.

I’ve also tried without creating a .pak file. I am sure the path is right (see screenie below). No idea why it keeps failing to find the .uproject…

The upper left console window shows the command I used to start the game.

http://www.team-imx.com/images/UE4/screenie_mac.jpg

  1. .ini file configuration

The other thing is that I’m having a very hard time finding any info on how the .ini files work and how to set parameters correctly.

As a concrete example: How would I set the initial resolution (as above) in an .ini file for the game (all levels)?

Any hints are greatly appreciated!

Cheers,
Michael

Okay, I’ve run out of ideas on how to get this packaging working on the Mac.

Is this really that badly broken or am I missing something critical?

Here’s my current issue list:

  • Packaging with “pak” enabled gives me the “Failed to open descriptor file…”
  • Packaging witout the “pak” option and referencing the .uproject file directly gives me the same error (and I am 100% sure the paths are correct)
  • What’s this with the naming? I have no idea how UE dreams up the names for the executable and the .uprjoject it fails to reference
  • I haven’t yet figured out how to get the ini files settings right on the Mac (documentation is very scarce on this as far as I have seen)
  • Running the game as shown above does not work (“Failed to…”)
  • Right-Clicking the .uproject file (the original, NOT the packaged one) and choosing “launch game” runs the game
  • Right-Clicking the .uproject file (the packaged one) and choosing “launch game” starts the game, shows the EPIC splash screen and then dies

Anyone got this working?

Cheers,
Michael

Lets just say I had a similar issue with a file in the UE4. Like you I couldn’t find the settings somewhere in the editor of what is was asking for so I could point it somewhere else.

So I broke out MVSE 2014 and started opening up my projects code files and looking through them for something that had that exact same object or directory or whatever called for. Once I found it and looked at the path it was calling all I did was just change the path in the code and it solved my problem.

So pull out notepad ++ or something and look over the code for where that path is stated and change it.

Hmm okay. I think I’ll do a temporary fix in our fork of the source, I need to get this more automated.

you might be just not doing it right. I am using the Mac version fine and builds run okay with the command line args.

@cgbeige: It’s not just the cmd line startup stuff, there’s quite a lot not working properly.

But anyways, I did a fix in our fork of the sourcedode, it works here too now.