Download

Issues with line trace by channel

Before I tell you the error I want this to be clear, WITHOUT CHANGING ANYTHING I went from version 4.22.3 to version 4.26.1, before changing the version line trace by channel worked excellent, now in the new version I have problems, the line trace does not collide with the AI’s, I repeat I DO NOT CHANGE ANYTHING this “suddenly appears” any recommendations? I have the collisions well, the line trace by channel is in visibility and the actors block visibility and the other error I have is that my projectile does not collide with the AI’s, if it collides with meshes and with the terrain, I repeat myself do not change anything and everything worked excellent in version 4.22.3 everything started to fail in version 4.26.1, one more thing, projectile and line trace collide with the AI’s but ONLY in the center of the mesh in the “hips”

Check for deprecations and changes within the engine for 4.23, 4.24, 4.25, 4.26

Thanks for answering, I read everything but I didn’t find anything related to the line traces, so I’m still in the same

Look at your actors etc. Verify settings and logic. Look for settings in said actors that are deprecated or have been modified. Line traces are solid.

I tried several changes in those affected, the ones that fail are the characters, change the configurations of line traces, create a new channel of line traces, I put them to block it and nothing happens, create an actor and inside it I put a mesh, in that case if it blocks and if it reacts to my shots, but not in the characters, I made changes but nothing worked and I don’t know what I have to “fix” because this worked excellent 1 week ago … any other ideas? The only thing that blocks my line trace is the capsule component, but not the mesh, I need the mesh because I have it configured so that if I hit a bone, for example, the head, the enemy will die automatically

The capsule component and skeletal mesh component both have object type Pawn by default. I added a new object type (Pawn Capsule) in the project settings to allow for mesh hits ignoring the capsule. If you did the same check if your custom object types got ported over and they are applied correctly.